File: 2320.txt

package info (click to toggle)
snort 2.9.7.0-5
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid, stretch
  • size: 55,000 kB
  • ctags: 38,464
  • sloc: ansic: 266,667; sh: 12,508; makefile: 2,908; yacc: 497; perl: 496; lex: 261; sed: 14
file content (60 lines) | stat: -rw-r--r-- 1,125 bytes parent folder | download | duplicates (6)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
Rule:  

--
Sid:
2320

--
Summary:
This event is generated when an attempt is made to exploit a known
vulnerability in Ebola from PLD Software.

--
Impact:
Serious. Execution of arbitrary code may be possible.

--
Detailed Information:
Ebola from PLD Software is used to improve the performance of Anti-Virus
solutions on Linux systems.

A buffer overflow condition is present in the authentication mechanism
such that it may be triggered by the generation of an error message from
an unsuccessful authentication attempt.

--
Affected Systems:
	All versions of Ebola prior to 0.1.5

--
Attack Scenarios:
An attacker can send specially crafted authentication attempts to the Ebola system and
cause the buffer overflow thus presenting the opportunity to execute
arbitrary code.

--
Ease of Attack:
Simple. Expoits exist.

--
False Positives:
None known.

--
False Negatives:
None known.

--
Corrective Action:
Upgrade to the latest non-affected version of the software.

--
Contributors:
Sourcefire Research Team
Brian Caswell <bmc@sourcefire.com>
Nigel Houghton <nigel.houghton@sourcefire.com>

-- 
Additional References:

--