1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38
|
export DH_VERBOSE := 1
mandir := $(CURDIR)/debian/man
debfolder := $(CURDIR)/debian
export LC_ALL=C
%:
dh $@
override_dh_auto_clean:
$(MAKE) clean
rm -rf debian/findknownsnps.1
rm -rf debian/findknownsnps.1.html
rm -f mapcontigs reassemble ungap
dh_auto_clean --
override_dh_installdocs:
antiword doc/Manual.doc > doc/Manual.txt
mkdir -p debian/snpomatic/usr/share/doc/snpomatic
cp doc/Manual.txt debian/snpomatic/usr/share/doc/snpomatic
mkdir -p debian/snpomatic/usr/share/doc-base
cp debian/doc-base debian/snpomatic/usr/share/doc-base/snpomatic-doc
dh_installdocs --
override_dh_auto_install:
mkdir -p $(debfolder)/snpomatic/usr/bin
install -p findknownsnps $(debfolder)/snpomatic/usr/bin
override_dh_installman:
asciidoctor -a docdate='' -b manpage debian/findknownsnps.1.adoc
dh_installman --
|