File: changelog

package info (click to toggle)
soapysdr 0.6.1-4
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 796 kB
  • sloc: cpp: 3,787; ansic: 428; python: 218; makefile: 18; sh: 11
file content (127 lines) | stat: -rw-r--r-- 4,752 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
soapysdr (0.6.1-4) unstable; urgency=medium

  * Build-Depend on python*-dev instead of python*-all-dev (Closes: 904095)
  * Bump Standards-Version to 4.2.0, no changes required

 -- Andreas Bombe <aeb@debian.org>  Wed, 22 Aug 2018 01:43:50 +0200

soapysdr (0.6.1-3) unstable; urgency=medium

  * Adapt Vcs-* fields in debian/control to changed path on salsa.debian.org
  * Add Build-Depends on python3-distutils since it isn't pulled in by
    python3 anymore
  * Use https URL for debian/copyright Format header

 -- Andreas Bombe <aeb@debian.org>  Fri, 23 Mar 2018 02:18:49 +0100

soapysdr (0.6.1-2) unstable; urgency=medium

  * Let python3-soapysdr recommend the correct python3-numpy instead of
    python-numpy
  * Make use of dh-python for Python library packages
  * Change Vcs fields in debian/control to point to new repository location
    on salsa.debian.org
  * Bump Standards-Version to 4.1.3, no changes required
  * Increase debhelper compat level to 11
  * Remove lintian override for doxygen embedded javascript library, not
    needed anymore

 -- Andreas Bombe <aeb@debian.org>  Mon, 05 Feb 2018 03:29:42 +0100

soapysdr (0.6.1-1) unstable; urgency=medium

  * New upstream version 0.6.1
  * Bump Standards-Version to 4.1.2, no changes required

 -- Andreas Bombe <aeb@debian.org>  Sun, 17 Dec 2017 22:12:11 +0100

soapysdr (0.6.0-2) unstable; urgency=medium

  * Let libsoapysdr-dev provide libsoapysdr0.6-dev so that module packages
    can Build-Depend on a version matching their binary package names
  * Bump Standards-Version to 4.0.1, no changes required

 -- Andreas Bombe <aeb@debian.org>  Sun, 06 Aug 2017 12:12:35 -0400

soapysdr (0.6.0-1) unstable; urgency=medium

  * New upstream version 0.6.0
  * Change library ABI version in package names and dependencies from 0.5-2
    to 0.6
  * Update copyright years in debian/copyright
  * Add soapysdr0.6-module-osmosdr dependency to the soapysdr0.6-module-all
    metapackage
  * Bump Standards-Version to 4.0.0, no changes required
  * Fix CMake warning for mismatched logical block arguments in version-string
    patch
  * Include pkg-info.mk in debian/rules instead of setting DEB_VERSION
    manually with dpkg-parsechangelog

 -- Andreas Bombe <aeb@debian.org>  Tue, 27 Jun 2017 02:57:04 +0200

soapysdr (0.5.4-1) unstable; urgency=medium

  * New upstream version 0.5.4
  * Refresh version-string patch
  * Add airspy, lms7 and redpitaya dependencies to soapysdr0.5-2-module-all
  * Mask dependencies of soapysdr0.5-2-module-all for architectures where
    the modules can't be built
  * Remove man page for SoapySDRUtil, merged upstream
  * Remove unnecessary dh_installchangelogs override from debian/rules
  * Link with --as-needed

 -- Andreas Bombe <aeb@debian.org>  Fri, 06 Jan 2017 19:24:08 +0100

soapysdr (0.5.3-2) unstable; urgency=medium

  * Add man page for SoapySDRUtil
  * Add hackrf, remote and uhd dependencies to soapysdr0.5-2-module-all
  * Add appropriate Multi-Arch headers to libsoapysdr-dev, libsoapysdr-doc,
    soapysdr0.5-2-module-all, soapysdr-module-all
  * Move debhelper compat level from 9 to 10
  * Call dh_doxygen after dh_installdocs

 -- Andreas Bombe <aeb@debian.org>  Sat, 19 Nov 2016 23:09:15 +0100

soapysdr (0.5.3-1) unstable; urgency=medium

  * New upstream version 0.5.3
  * Add soapysdr-module-all metapackages that depend on all available
    module packages and let libsoapysdr recommend it as the first
    alternative to the virtual soapysdr-module package

 -- Andreas Bombe <aeb@debian.org>  Mon, 19 Sep 2016 20:00:52 +0200

soapysdr (0.5.2-1) unstable; urgency=medium

  * New upstream version 0.5.2
  * Add patch install-dev-docs to make the build install the HTML
    documentation files
  * Add Build-Depends-Indep on doxygen and create new architecture all
    package libsoapysdr-doc

 -- Andreas Bombe <aeb@debian.org>  Wed, 24 Aug 2016 04:06:10 +0200

soapysdr (0.5.1-1) unstable; urgency=medium

  * New upstream version 0.5.1
    - Modules are now searched in ABI versioned path to facilitate
      parallel installation of multiple libsoapysdr ABI versions
  * Recommend module virtual package in shared library package which is
    provided by hardware support module packages
  * Add DEP3 header to version-string patch

 -- Andreas Bombe <aeb@debian.org>  Mon, 15 Aug 2016 20:45:32 +0200

soapysdr (0.4.3+git20160605-2) unstable; urgency=medium

  * Remove symbols file again, too much work for a C++ library for now
  * Move to team maintenance by the hamradio team

 -- Andreas Bombe <aeb@debian.org>  Sun, 10 Jul 2016 13:45:50 +0200

soapysdr (0.4.3+git20160605-1) unstable; urgency=medium

  * Initial release. (Closes: #827709)

 -- Andreas Bombe <aeb@debian.org>  Fri, 08 Jul 2016 16:15:23 +0200