File: FAQ

package info (click to toggle)
solfege 2.0.4-4
  • links: PTS
  • area: main
  • in suites: sarge
  • size: 3,200 kB
  • ctags: 1,844
  • sloc: python: 12,160; xml: 5,458; ansic: 1,486; makefile: 562; sh: 233
file content (59 lines) | stat: -rw-r--r-- 2,106 bytes parent folder | download | duplicates (3)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
FAQ
***

The window title does not display non-ascii characters
======================================================

... everything look like: "Solfege \x{0414}\x{0438}\x{0442}..."

   This is because your window manager does not display unicode fonts.
Try a window manager that can handle unicode fonts, for example
metacity.

The program crashes at startup!
===============================

Try to start the program with the `--no-sound'. If the program starts,
then you probably has to check the sound setup for your kernel. If you
for example have a Soundblaster 32 and unloads the `awe_wave' module,
Solfege will crash when it tries to open `/dev/music'.

Solfege still crashes!!
=======================

Are you running Ximian (aka Helix) GNOME? Some (all??) versions of the
"monkeytalk" package are known to make pygtk apps crash. Try to remove
the package.

ValueError: invalid literal for float():
========================================

If you want translated messages, you should only set the `LC_MESSAGES'
environment variable, not `LC_ALL' or `LC_NUMERIC'. If your window
manager set these variable, you can avoid the problem by running
solfege like this:

   `LC_NUMERIC=C solfege'

   You can run the `locale' command to see what environment variables
controlling locales are set.

Some menu entries are blank when I use language other than english.
===================================================================

If you are running Debian with glibc > 2.2, try to rerun `locale-gen'
as root, and maybe edit `/etc/locale.gen'.

I get a lame piano sound in the rhythm exercise!
================================================

From the preferences window, on the config page, change the number in
the spin button, and click 'Apply'. Some sound cards have several
synths, and not all behave the same. For example, on my SB Live using
ALSA I have to select number 2.

   Also if you use the standard OSS sound driver and `/dev/sequencer'
instead of  `/dev/music' you might be missing the percussion sounds.
If you have a Soundblaster AWE32/AWE64/pnp32, you must select that
option.