1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54
|
export LC_ALL=C.UTF-8
export HOME=$(CURDIR)/tmp
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
include /usr/share/dpkg/buildflags.mk
DEB_CXXFLAGS_MAINT_APPEND=-std=c++14 $(CPPFLAGS)
DEB_LDFLAGS_MAINT_APPEND=
ifneq (,$(filter $(DEB_HOST_ARCH), i386))
DEB_CXXFLAGS_MAINT_APPEND+=-ffloat-store
endif
DEB_LDFLAGS_MAINT_APPEND+= -Wl,--as-needed
export DEB_CXXFLAGS_MAINT_APPEND
export DEB_LDFLAGS_MAINT_APPEND
export QT_SELECT=qt5
vamp-capnp=$(CURDIR)/piper-vamp-cpp/vamp-capnp
%:
dh $@
override_dh_auto_build:
mkdir -p $(CURDIR)/tmp
cp $(CURDIR)/debian/missing-sources/piper.capnp \
$(vamp-capnp)
dh_auto_build
override_dh_auto_clean:
dh_auto_clean
rm -f $(vamp-capnp)/piper.capnp
rm -f $(vamp-capnp)/piper.capnp.c++
rm -f $(vamp-capnp)/piper.capnp.h
rm -rf $(CURDIR)/tmp
override_dh_auto_install:
dh_auto_install -- \
INSTALL_ROOT='$$(DESTDIR)' \
$(empty)
rm -rf $(CURDIR)/debian/*/usr/tests/
find $(CURDIR)/debian/sonic-visualiser/usr/bin/ -type f -name "*vamp*" -delete
licensecheck:
licensecheck --deb-machine -r * \
> debian/copyright_newhints
cmp debian/copyright_hints debian/copyright_newhints \
&& rm debian/copyright_newhints
|