File: changelog

package info (click to toggle)
soundkonverter 3.0.1-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 5,012 kB
  • sloc: cpp: 30,779; sh: 59; xml: 50; makefile: 7
file content (262 lines) | stat: -rw-r--r-- 9,122 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
soundkonverter (3.0.1-2) unstable; urgency=medium

  * Team upload.
  * Bump the debhelper compatibility to 13:
    - switch the debhelper build dependency to debhelper-compat 13
    - remove debian/compat
    - stop passing --parallel, as it is the default now
  * Remove the explicit as-needed linking, as it is done by binutils now.
  * Switch Vcs-* fields to salsa.debian.org.
  * Add the configuration for the CI on salsa.
  * Backport upstream commit 3760bccb3aa1e15bd5ec67bc977717c55a95bc6e to fix
    the cmake search and use of taglib; patch
    upstream_FindTaglib.cmake-Update-local-copy-with-ECM-5.72.0-v.patch
    (Closes: #973221)
  * Trim trailing whitespace.
  * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
    Repository-Browse.
  * Bump Standards-Version to 4.5.0, no changes required.
  * Add Rules-Requires-Root: no.
  * Explicitly add the gettext build dependency.

 -- Pino Toscano <pino@debian.org>  Sat, 07 Nov 2020 11:42:25 +0100

soundkonverter (3.0.1-1) unstable; urgency=medium

  * Team upload.

  [ Maximiliano Curia ]
  * Update uploaders list as requested by MIA team (Closes: #879436)

  [ Pino Toscano ]
  * New upstream release:
    - switches to Qt5/KF5 (Closes: #875187)
  * Update the build dependencies following the port to Frameworks:
    - remove kdelibs5-dev, and libkcddb-dev
    - add extra-cmake-modules, qtbase5-dev, libkf5config-dev,
      libkf5configwidgets-dev, libkf5i18n-dev, libkf5kdelibs4support-dev,
      libkf5kio-dev, libkf5solid-dev, libkf5widgetsaddons-dev,
      libkf5xmlgui-dev, libkf5cddb-dev, and libphonon4qt5-dev
  * Use the right dh addon:
    - switch from kde to kf5 dh addon
    - bump the pkg-kde-tools build dependency to >= 0.15.16
  * Update the patches:
    - soversion.diff: refresh
  * Remove trailing whitespaces in changelog.
  * Update lintian overrides.
  * Bump Standards-Version to 4.1.3, no changes required.

 -- Pino Toscano <pino@debian.org>  Thu, 28 Dec 2017 14:16:46 +0100

soundkonverter (2.2.2-1) unstable; urgency=medium

  * Team upload.
  * New upstream release.
  * Update watch file.
  * Update Homepage to the GitHub location.
  * Update Vcs-* fields.
  * Convert rules to the dh sequencer with compat 9:
    - bump the debhelper build dependency to 9
    - remove the cdbs build dependency
    - bump compat to 9
    - make use of the kde dh addon, adding the pkg-kde-tools build dependency
      for it
    - drop all the manual install/cleanup rules, no more needed
  * Remove the dpkg-dev build dependency, satisfied in Wheezy already and not
    useful anymore
  * Remove postinst and postrm autoscripts, since this is something done by
    debhelper automatically.
  * Remove dirs file, there is no need to create them manually anymore.
  * Fix typo in README.Debian.
  * Install README.md instead of README.
  * Install the CHANGES from the src subdirectory.
  * Set a SONAME for the private soundkonvertercore library; patch
    soversion.diff.
    - do not ship the .so symlinks
  * Bump Standards-Version to 3.9.8, no changes required.
  * Update lintian overrides.
  * Update the recommends:
    - libav-tools -> ffmpeg
    - kdemultimedia-kio-plugins -> kio-audiocd (Closes: #779419)
  * Link in as-needed mode.

 -- Pino Toscano <pino@debian.org>  Tue, 05 Jul 2016 14:19:23 +0200

soundkonverter (2.1.2-1) unstable; urgency=medium

  * Imported Upstream version 2.1.2
  * Bumped Standards-Version to 3.9.6, no changes needed.

 -- Michael Meskes <meskes@debian.org>  Fri, 27 Feb 2015 13:53:15 +0100

soundkonverter (2.1.1-1) unstable; urgency=medium

  * Imported Upstream version 2.1.1

 -- Michael Meskes <meskes@debian.org>  Mon, 14 Apr 2014 11:01:33 +0200

soundkonverter (2.0.5-1) unstable; urgency=medium

  * Imported Upstream version 2.0.5 (Closes: #736553)
  * Recommend libav-tools instead of ffmpeg which no longer exists.
    (Closes: #722428)
  * Bumped Standards-Version to 3.9.5, no changes needed.

 -- Michael Meskes <meskes@debian.org>  Sat, 25 Jan 2014 11:38:02 +0100

soundkonverter (2.0.4-1) unstable; urgency=low

  * New Upstream Release
  * Update Vcs headers
  * Update debian/watch

 -- Mark Purcell <msp@debian.org>  Sun, 04 Aug 2013 08:20:55 +1000

soundkonverter (2.0.3-1) unstable; urgency=low

  * Imported Upstream version 2.0.3

 -- Michael Meskes <meskes@debian.org>  Sat, 22 Jun 2013 11:43:15 +0200

soundkonverter (2.0.2-1) unstable; urgency=low

  * Imported Upstream version 2.0.2

 -- Michael Meskes <meskes@debian.org>  Thu, 09 May 2013 12:47:30 +0200

soundkonverter (2.0.1-1) unstable; urgency=low

  * Imported Upstream version 2.0.1

 -- Michael Meskes <meskes@debian.org>  Thu, 25 Apr 2013 12:56:10 +0200

soundkonverter (2.0.0-1) unstable; urgency=low

  * Updated watchfile to the latest version, courtesy of Bart Martens
    <bartm@debian.org>.
  * Imported Upstream version 2.0.0

 -- Michael Meskes <meskes@debian.org>  Sat, 23 Mar 2013 20:55:06 +0100

soundkonverter (1.9.90-1) unstable; urgency=low

  * Imported Upstream version 1.9.90

 -- Michael Meskes <meskes@debian.org>  Tue, 26 Feb 2013 14:25:14 +0100

soundkonverter (1.9.80-1) unstable; urgency=low

  * Imported Upstream version 1.9.80
  * Bumped Standards-Version to 3.9.4, no changes needed.
  * Don't mention cdda2wav anymore.

 -- Michael Meskes <meskes@debian.org>  Tue, 29 Jan 2013 10:45:26 +0100

soundkonverter (1.6.4-1) unstable; urgency=low

  * Imported Upstream version 1.6.4
  * Added working watch file.
    Thanks to Bart Martens <bartm@debian.org>
  * Use dpkg-buildflags for package hardening.
  * Added dpkg-dev build dependency needed for dpkg-buildflags inclusion.

 -- Michael Meskes <meskes@debian.org>  Mon, 07 Jan 2013 12:09:22 +0100

soundkonverter (1.5.0-1) unstable; urgency=low

  * Imported Upstream version 1.5.0
  * Bumped Standards-Version to 3.9.3, no changes needed.
  * Removed watch file again, because it no longer works.

 -- Michael Meskes <meskes@debian.org>  Thu, 10 May 2012 15:06:06 +0200

soundkonverter (1.3.2-1) unstable; urgency=low

  * New upstream version 1.3.2

 -- Michael Meskes <meskes@debian.org>  Sun, 19 Feb 2012 15:52:30 +0100

soundkonverter (1.2.1-1) unstable; urgency=low

  * Added watch file.
  * Removed linker patch because it was applied upstream.
  * New upstream version.
    (Closes: #456950, #485081, #513679, #582409, #593084, #653448)
  * Bumped Standards-Version to 3.9.2, no changes needed.

 -- Michael Meskes <meskes@debian.org>  Wed, 11 Jan 2012 13:02:57 +0100

soundkonverter (0.9.94-2) unstable; urgency=low

  * Made build system cope with upcoming linker changes.

 -- Michael Meskes <meskes@debian.org>  Fri, 11 Feb 2011 11:02:10 +0100

soundkonverter (0.9.94-1) unstable; urgency=low

  * Imported Upstream version 0.9.94 (Closes: #595372, #602691)
  * Bump Standards-Version to 3.9.1 (no changes needed).

 -- Michael Meskes <meskes@debian.org>  Tue, 01 Feb 2011 10:35:10 +0100

soundkonverter (0.9.91-1) unstable; urgency=low

  * New Upstream version 0.9.91
  * Bump Standards-Version to 3.9.0 (no changes needed).

 -- Michael Meskes <meskes@debian.org>  Wed, 21 Jul 2010 11:28:07 +0200

soundkonverter (0.9.90-1) unstable; urgency=low

  * Imported Upstream version 0.9.90 for KDE4 which compiles fine with
    binutils-gold. (Closes: #556353)
  * Bump Standards-Version to 3.8.4 (no changes needed).
  * Moved to source version 3.0.
  * Added watch file.
  * Added missing build dependencies. (Closes: #565850)
  * Added information about git repository.
  * Added the word "Copyright" to copyright file to make lintian happy.

 -- Michael Meskes <meskes@debian.org>  Wed, 05 May 2010 09:15:31 +0200

soundkonverter (0.3.10-1) unstable; urgency=low

  * New upstream release.
  * Bump Standards-Version from 3.8.1 to 3.8.2 (no changes needed).

 -- Fathi Boudra <fabo@debian.org>  Sun, 05 Jul 2009 12:38:50 +0200

soundkonverter (0.3.8-3) unstable; urgency=low

  * Drop soundkonverter-amarok since it doesn't work with amarok 2.
    (Closes: #528350)
  * Add patch to fix ftbfs with gcc 4.4. Thanks to Martin Michlmayr.
    (Closes: #505724)
  * Bump Standards-Version from 3.8.0 to 3.8.1 (no changes needed).

 -- Fathi Boudra <fabo@debian.org>  Tue, 12 May 2009 16:04:07 +0200

soundkonverter (0.3.8-2) unstable; urgency=low

  * Changed build dependency from automake-1.9 to automake. (Closes: #488814)

 -- Michael Meskes <meskes@debian.org>  Tue, 01 Jul 2008 16:16:14 +0200

soundkonverter (0.3.8-1) unstable; urgency=low

  * New upstream version. (Closes: #488227)
  * Made amarok script list the current version number. (Closes: #447623)
  * Added a note to README.Debian about how to enable soundkonverter-amarok
    script. (Closes: #447625)
  * Moved homepage in description to its own field.
  * Made lintian happy by slightly rewording copyright file.
  * Bumped Standards-Version to 3.8.0, no changes needed.
  * Added myself as uploader.

 -- Michael Meskes <meskes@debian.org>  Fri, 27 Jun 2008 12:38:16 +0200

soundkonverter (0.3.6-1) unstable; urgency=low

  * Initial release. (Closes: #446403)

 -- Fathi Boudra <fboudra@free.fr>  Sat, 13 Oct 2007 14:50:28 +0200