1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105
|
OPENGL_ES_ARCHS := armhf armel
FLAVORS = nox
ifneq (,$(findstring $(DEB_HOST_ARCH), $(OPENGL_ES_ARCHS)))
export DH_OPTIONS=-Nsoundscaperenderer
else
FLAVORS += qt
endif
builddir=debian/build/flavor-
DEB_BUILDDIR = build
export QT_SELECT=qt5
CONFIG = --disable-optimization \
--disable-dynamic-asdf \
$(empty)
CONFIG_qt = --enable-gui --program-suffix=.qt
CONFIG_nox = --disable-gui --program-suffix=.nox
CONFIG_indep = --program-suffix=.indep --disable-all \
--disable-gui \
--disable-ip-interface \
--disable-websocket-interface \
--disable-ecasound \
--disable-polhemus \
--disable-razor \
--disable-vrpn \
--disable-intersense \
--disable-isatty \
$(empty)
%:
dh $@
execute_before_dh_autoreconf:
mkdir -p autotools/config autotools/m4
override_dh_auto_configure-indep: configure_indep
override_dh_auto_configure-arch: $(patsubst %,configure_%,$(FLAVORS))
configure_%:
dh_auto_configure -B $(builddir)$* -- $(strip $(CONFIG) $(CONFIG_$*))
override_dh_auto_clean:
rm -rf $(patsubst %,$(builddir)%,$(FLAVORS) indep)
rmdir -p $(dir $(builddir)) || echo "couldn't cleanup build-dirs...ignoring"
rm -rf doc/manual/_build/
override_dh_auto_build-indep:
dh_auto_build -i --sourcedirectory=$(builddir)indep || (cat $(builddir)indep/config.log && exit 1)
$(CURDIR)/debian/scripts/alternatives $(CURDIR)/$(builddir)indep/src $(CURDIR)/$(builddir)indep/alternatives
make -C $(CURDIR)/doc/manual html
override_dh_auto_build-arch: $(patsubst %,build_%,$(FLAVORS))
build_%:
dh_auto_build -a --sourcedirectory=$(builddir)$* || (cat $(builddir)$*/config.log && exit 1)
$(CURDIR)/debian/scripts/alternatives $(CURDIR)/$(builddir)$*/src $(CURDIR)/$(builddir)$*/alternatives
override_dh_auto_install-indep:
dh_auto_install -i --sourcedirectory=$(builddir)indep
override_dh_auto_install-arch: $(patsubst %,install_%,$(FLAVORS))
install_%:
dh_auto_install -a --sourcedirectory=$(builddir)$*
override_dh_installman:
dh_installman --language=C
DEB_COPYRIGHT_CHECK_IGNORE_REGEX = \
debian/.*|flext/.*\.wav|data/impulse_responses/hrirs/.*\.wav|doc/manual/images/screenshot.*\.png|data/MacOSX/SSRIcon\.icns|data/MacOSX/\.background/background\.png|data/MacOSX/dylibbundler/dylibbundler\.png
.PHONY: licensecheck
licensecheck:
LANG=C.UTF-8 licensecheck \
-i "^($(DEB_COPYRIGHT_CHECK_IGNORE_REGEX))$$" \
--check '.*' --recursive --deb-machine --lines 0 * \
> debian/copyright_newhints
cmp debian/copyright_hints debian/copyright_newhints \
&& rm debian/copyright_newhints
|