File: changelog

package info (click to toggle)
spectools 201601r1-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid, stretch
  • size: 1,272 kB
  • ctags: 1,837
  • sloc: ansic: 18,708; sh: 2,476; makefile: 85
file content (142 lines) | stat: -rw-r--r-- 4,449 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
spectools (201601r1-1) unstable; urgency=medium

  * New upstream release
  * General maintenance
    - Adopt package (Closes: #777104)
    - Bump Standards-Version up to 3.9.8
    - Update Vcs-Git and Vcs-Browser URLs
    - Enable hardening flags
  * Upstream source tarball
    - Extend URL in debian/watch to support new upstream location
    - Add upstream/signing-key.asc for checking gpg signature
  * Add debian/patches:
    - fix_typos: Fix spelling errors
    - gcc5_fix: Enable support for GCC 5 builds
    - clang_fix: Enable support for clang builds (Closes: #741113)
      Thanks to Nicolas Sévelin-Radiguet for the initial patch

 -- Nick Andrik <nick.andrik@gmail.com>  Wed, 23 Nov 2016 00:28:10 +0100

spectools (201108r1-7) unstable; urgency=medium

  * Switch back to libusb 0.1.0 since 1.0 is not supported

 -- Francois Marier <francois@debian.org>  Sun, 10 Jan 2016 11:21:43 -0800

spectools (201108r1-6) unstable; urgency=medium

  * Switch to libusb 1.0 (closes: #810459)
  * Remove menu file (lintian warning)

 -- Francois Marier <francois@debian.org>  Sat, 09 Jan 2016 19:04:41 -0800

spectools (201108r1-5) unstable; urgency=medium

  * Team upload.

  [ Francois Marier ]
  * Run wrap-and-sort

  [ Raphaël Hertzog ]
  * Pass "-std=gnu89" to gcc to avoid build failures due to gcc now defaulting
    to C11. Closes: #778128

 -- Raphaël Hertzog <hertzog@debian.org>  Wed, 15 Jul 2015 20:38:21 +0200

spectools (201108r1-4) unstable; urgency=medium

  * Bump Standards-Version up to 3.9.6
  * Add keywords to the desktop file

 -- Francois Marier <francois@debian.org>  Fri, 19 Sep 2014 00:24:44 +1200

spectools (201108r1-3) unstable; urgency=medium

  * Bump Standards-Version up to 3.9.5
  * Switch to a machine-readable debian/copyright file
  * Use canonical VCS URLs in debian/control

 -- Francois Marier <francois@debian.org>  Sat, 01 Feb 2014 23:14:23 +1300

spectools (201108r1-2) unstable; urgency=low

  * Switch to a minimal debian/rules file
  * Fix watch file
  * Bump Standards-Version up to 3.9.3
  * Bump debhelper compatibility to 9

 -- Francois Marier <francois@debian.org>  Mon, 28 May 2012 12:36:25 +1200

spectools (201108r1-1) unstable; urgency=low

  * New upstream release

  * Remove obsolete "Break" (udev << 136) in debian/control
  * Add empty build-arch and build-indep targets in debian/rules
  * Bump Standards-Version up to 3.9.2

 -- Francois Marier <francois@debian.org>  Tue, 09 Aug 2011 15:40:32 -0400

spectools (201004R1-2) unstable; urgency=low

  * Bump Standards-Version up to 3.9.1
  * Bump debhelper compatibility to 8

 -- Francois Marier <francois@debian.org>  Wed, 22 Dec 2010 17:19:26 +1300

spectools (201004R1-1) unstable; urgency=low

  * New upstream release
  * Merge with Ubuntu:
    - debian/rules: Install udev rules into /lib/udev/rules.d
    - debian/dirs: Create new directory
    - debian/preinst: Remove old rules if unmodified.
    - debian/control: Add Breaks to ensure we have correct udev version.

  * Bump Standards-Version to 3.8.4
  * Switch to 3.0 (quilt) source package format

 -- Francois Marier <francois@debian.org>  Sat, 24 Apr 2010 12:49:46 +1200

spectools (200906R1-1) unstable; urgency=low

  * New Upstream Version
    - includes support for the Wi-Spy 24i (closes: #528803)

  * Bump Standards-Version to 3.8.2
  * Bump debhelper compatibility to 7
  * debian/rules: make use of dh_prep
  * debian/rules: stop using the deprecated dh_desktop

 -- Francois Marier <francois@debian.org>  Sat, 20 Jun 2009 18:45:51 +1200

spectools (200902R1-2) unstable; urgency=medium

  * Fix macro breaking several architectures (closes: #514141)

 -- Francois Marier <francois@debian.org>  Fri, 20 Feb 2009 19:14:42 +1300

spectools (200902R1-1) unstable; urgency=low

  * New Upstream Version
    - new utility: spectool_curses
  * Move repo to git
  * Bump Standards-Version to 3.8.0
  * Fix lintian notice regarding missing "copyright" word
  * Add libncurses5-dev to the build dependencies

 -- Francois Marier <francois@debian.org>  Wed, 04 Feb 2009 13:58:50 +1300

spectools (200710R2-2) unstable; urgency=low

  * Remove encoding from desktop file (fix lintian info)
  * Bump debhelper compatibility to 6

 -- Francois Marier <francois@debian.org>  Tue, 03 Jun 2008 15:06:19 +1200

spectools (200710R2-1) unstable; urgency=low

  * Initial release (Closes: #455692)

 -- Francois Marier <francois@debian.org>  Sun, 16 Dec 2007 22:07:06 +1300