1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88
|
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
include /usr/share/dpkg/pkg-info.mk
export deb_systemdsystemunitdir = $(shell pkgconf --variable=systemdsystemunitdir systemd | sed s,^/,,)
ifeq ($(shell dpkg-vendor --derives-from Ubuntu && echo yes),yes)
NAS = --with-nas=no
ifneq (,$(filter speech-dispatcher-festival,$(shell dh_listpackages)))
ifeq (${DEB_HOST_ARCH},i386)
builddeb_overrides = -Nspeech-dispatcher-festival
endif
endif
endif
CONFIGURE=--with-module-bindir=\$${prefix}/lib/speech-dispatcher-modules \
pidpath=/run/speech-dispatcher/ $(NAS)
ifeq ($(DEB_SOURCE),speech-dispatcher)
CONFIGURE += --with-baratinoo=no --with-ibmtts=no --with-voxin=no --with-kali=no --with-ivona=no
endif
CONFIGURE_ARCH=--disable-python
%:
dh $@
config/modules/espeak-ng-mbrola-generic.conf:
for i in espeak-ng-mbrola-generic.conf \
espeak-mbrola-generic.conf ; do \
sed < config/modules/$$i.in > config/modules/$$i -e "s/\$$DEB_HOST_MULTIARCH/$(DEB_HOST_MULTIARCH)/" ; \
done
override_dh_auto_configure-arch: config/modules/espeak-ng-mbrola-generic.conf
dh_auto_configure -- $(CONFIGURE) $(CONFIGURE_ARCH)
override_dh_auto_configure-indep: config/modules/espeak-ng-mbrola-generic.conf
dh_auto_configure -- $(CONFIGURE)
override_dh_auto_install:
@echo blhc: ignore-line-regexp: libtool: link:.*
dh_auto_install --destdir=debian/tmp
ifeq ($(DEB_SOURCE),speech-dispatcher)
override_dh_installinit:
dh_installinit -a --error-handler=true --no-enable --no-start
override_dh_fixperms-arch:
dh_fixperms
chmod 700 $(CURDIR)/debian/speech-dispatcher/var/log/speech-dispatcher
override_dh_makeshlibs:
dh_makeshlibs -plibspeechd2
endif
override_dh_builddeb:
dh_builddeb ${builddeb_overrides}
override_dh_gencontrol:
dh_gencontrol ${builddeb_overrides}
override_dh_installsystemd:
dh_installsystemd --no-enable --no-start
main:
sed -i 's/^speech-dispatcher-contrib /speech-dispatcher /' debian/changelog
sed -i '1s/^Source: speech-dispatcher-contrib$$/Source: speech-dispatcher/' debian/control
sed -i 's/^ libttspico-dev/
sed -i 's/^
sed -i '/^
sed -i '/Package: speech-dispatcher$$/,$$s/^
sed -i '1,/^$$/s_^Section: contrib/_Section: _' debian/control
contrib:
sed -i 's/^speech-dispatcher /speech-dispatcher-contrib /' debian/changelog
sed -i '1s/^Source: speech-dispatcher$$/Source: speech-dispatcher-contrib/' debian/control
sed -i 's/^
sed -i 's/^ help2man/
sed -i '/^
sed -i '/Package: speech-dispatcher$$/,$$s/^/
sed -i '1,/^$$/s_^Section: \([^/]*\)$$_Section: contrib/\1_' debian/control
|