1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs
export DPKG_GENSYMBOLS_CHECK_LEVEL = 4
ifneq ($(DEB_HOST_ARCH_OS),linux)
conf_flags += -Dlibcap-ng=disabled
endif
%:
dh $@
override_dh_auto_configure:
dh_auto_configure -- \
-Dauto_features=enabled \
-Dusb-acl-helper-dir=/usr/libexec \
-Dusb-ids-path=/usr/share/misc/usb.ids \
$(conf_flags)
execute_after_dh_auto_install:
sed -E -i '/^(Libs|Requires)\.private:/D' debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/pkgconfig/spice-client-glib-2.0.pc
sed -E -i '/^(Libs|Requires)\.private:/D' debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/pkgconfig/spice-client-gtk-3.0.pc
execute_after_dh_fixperms:
chmod 4755 debian/spice-client-glib-usb-acl-helper/usr/libexec/spice-client-glib-usb-acl-helper
|