File: control

package info (click to toggle)
spidermonkey 1.5rc6a-1
  • links: PTS
  • area: main
  • in suites: sarge
  • size: 6,676 kB
  • ctags: 11,462
  • sloc: ansic: 82,178; cpp: 11,392; java: 859; perl: 722; makefile: 638; asm: 75; awk: 20; sh: 7
file content (56 lines) | stat: -rw-r--r-- 2,107 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
Source: spidermonkey
Priority: optional
Maintainer: Marek Habersack <grendel@debian.org>
Build-Depends: debhelper (>> 4.0.0), libnspr-dev, libreadline4-dev, pkg-config
Standards-Version: 3.6.1

Package: spidermonkey-bin
Section: interpreters
Architecture: any
Depends: ${shlibs:Depends}, libnspr4 (>= ${nspr:ver})
Description: Binaries of the SpiderMonkey interpreter
 This package contains the standalone JavaScript interpeter
 from the SpiderMonkey JS library.

Package: libsmjs-dev
Section: libdevel
Architecture: any
Depends: libsmjs1 (= ${Source-Version}), libnspr-dev
Conflicts: spidermonkey-dev (<= 1.5rc5a-1)
Replaces: spidermonkey-dev (<= 1.5rc5a-1)
Description: Development files for the SpiderMonkey JS library
 This package contains the development files (includes and
 static libraries) you will need if you want to embed the
 SpiderMonkey JavaScript engine in your application.

Package: libsmjs1
Section: libs
Architecture: any
Depends: ${shlibs:Depends}, libnspr4 (>= ${nspr:ver})
Conflicts: spidermonkey1 (<= 1.5rc5a-1)
Replaces: spidermonkey1 (<= 1.5rc5a-1)
Description: The Mozilla SpiderMonkey JavaScript library
 This package contains the shared library of the embeddable
 JavaScript engine from the Mozilla project (used among others
 by the Mozilla, Galeon, Netscape6 browsers as well as by the
 iPlanet WebServer) called SpiderMonkey.

Package: spidermonkey-dev
Section: libdevel
Architecture: any
Depends: libsmjs-dev (>= ${Source-Version})
Description: Migration package for the SpiderMonkey JS library
 This package exists solely for the purpose of migrating from
 the old package naming to the new one. It contains no files
 and therefore can be removed without any problems after the
 upgrade is completed.

Package: spidermonkey1
Section: libdevel
Architecture: any
Depends: libsmjs1 (>= ${Source-Version})
Description: Migration package for the SpiderMonkey JS library
 This package exists solely for the purpose of migrating from
 the old package naming to the new one. It contains no files
 and therefore can be removed without any problems after the
 upgrade is completed.