1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102
|
Source: sqlobject
Section: python
Priority: optional
Build-Depends: debhelper-compat (= 12),
dh-python,
python3-all,
python3-formencode,
python3-pydispatch,
python3-setuptools,
# Documentation
python3-sphinx,
# Used in the test suite
python3-pytest
Maintainer: Debian Python Team <team+python@tracker.debian.org>
Uploaders: Neil Muller <drnlmuller+debian@gmail.com>
Standards-Version: 4.5.1.0
Rules-Requires-Root: no
Vcs-Git: https://salsa.debian.org/python-team/packages/sqlobject.git
Vcs-Browser: https://salsa.debian.org/python-team/packages/sqlobject
Homepage: http://www.sqlobject.org
Package: python3-sqlobject
Architecture: all
Depends: python3-formencode,
python3-pydispatch,
python3-pkg-resources,
${misc:Depends},
${python3:Depends}
Recommends: sqlobject-admin (= ${source:Version})
Suggests: python3-mysqldb,
python3-psycopg2,
python-sqlobject-doc
Description: Python 3 object relational manager providing an object interface to databases
SQLObject is an object-relational mapper. It allows you to translate RDBMS
table rows into Python objects, and manipulate those objects to transparently
manipulate the database.
.
In using SQLObject, you will create a class definition that will describe how
the object connects to the database (in addition to any other methods you may
wish to add to the class). SQLObject will produce the code to access the
database, and update the database with your changes. The interface to the
database is meant to be indistinguishable from other interfaces you may add
to the object.
.
SQLObject also includes a novel feature to generate WHERE clauses using
Python syntax and objects (instead of generating SQL using string
substitution, as is traditional).
.
This is the Python 3 version of SQLObject.
Package: python-sqlobject-doc
Section: doc
Architecture: all
Multi-Arch: foreign
Depends: ${misc:Depends},
${sphinxdoc:Depends}
Breaks: python-sqlobject (<< 3.0.0+dfsg-1)
Replaces: python-sqlobject (<< 3.0.0+dfsg-1)
Description: Documentation for SQLObject, a Python object relational manager for databases
This is the documentation for SQLObject. SQLObject is an object-relational
mapper. It allows you to translate RDBMS table rows into Python objects, and
manipulate those objects to transparently manipulate the database.
.
In using SQLObject, you will create a class definition that will describe how
the object connects to the database (in addition to any other methods you may
wish to add to the class). SQLObject will produce the code to access the
database, and update the database with your changes. The interface to the
database is meant to be indistinguishable from other interfaces you may add
to the object.
.
SQLObject also includes a novel feature to generate WHERE clauses using
Python syntax and objects (instead of generating SQL using string
substitution, as is traditional).
.
The documentation covers the Python 3 versions of SQLObject.
Package: sqlobject-admin
Architecture: all
Section: utils
Depends: python3-sqlobject (= ${source:Version}),
${misc:Depends},
${python3:Depends}
Breaks: python-sqlobject (<< 3.0.0+dfsg-1)
Replaces: python-sqlobject (<< 3.0.0+dfsg-1)
Description: Helper applications for SQLObject, a Python ORM for databases
SQLObject is an object-relational mapper. It allows you to translate RDBMS
table rows into Python objects, and manipulate those objects to transparently
manipulate the database.
.
In using SQLObject, you will create a class definition that will describe how
the object connects to the database (in addition to any other methods you may
wish to add to the class). SQLObject will produce the code to access the
database, and update the database with your changes. The interface to the
database is meant to be indistinguishable from other interfaces you may add
to the object.
.
SQLObject also includes a novel feature to generate WHERE clauses using
Python syntax and objects (instead of generating SQL using string
substitution, as is traditional).
.
This package includes the sqlobject-admin and sqlobject-convertOldURI helper
applications for use with SQLObject.
|