File: control

package info (click to toggle)
squirrel3 3.1-7
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 1,336 kB
  • sloc: cpp: 12,721; ansic: 917; makefile: 316; python: 40
file content (62 lines) | stat: -rw-r--r-- 2,195 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
Source: squirrel3
Maintainer: Fabian Wolff <fabi.wolff@arcor.de>
Section: interpreters
Priority: optional
Build-Depends: debhelper (>= 10),
               cmake,
               python3-sphinx | python-sphinx,
               texlive,
               texlive-latex-extra,
               texlive-generic-extra,
               latexmk
Standards-Version: 4.3.0
Homepage: http://squirrel-lang.org/
Vcs-Git: https://salsa.debian.org/wolff-guest/squirrel3.git/
Vcs-Browser: https://salsa.debian.org/wolff-guest/squirrel3

Package: squirrel3
Architecture: any
Multi-Arch: no
Depends: libsquirrel3-0 (= ${binary:Version}),
         ${misc:Depends},
         ${shlibs:Depends}
Description: lightweight, high-level, embeddable programming language
 Squirrel is a high-level imperative, object-oriented programming
 language, designed to be a lightweight scripting language that fits
 in the size, memory bandwidth, and real-time requirements of
 applications like video games.
 .
 This package contains the Squirrel command line interpreter and
 bytecode compiler.

Package: libsquirrel3-0
Architecture: any
Multi-Arch: same
Section: libs
Depends: ${misc:Depends},
         ${shlibs:Depends}
Pre-Depends: ${misc:Pre-Depends}
Description: runtime libraries for the Squirrel programming language
 Squirrel is a high-level imperative, object-oriented programming
 language, designed to be a lightweight scripting language that fits
 in the size, memory bandwidth, and real-time requirements of
 applications like video games.
 .
 This package contains runtime libraries. You shouldn't have to
 install it manually.

Package: libsquirrel-dev
Architecture: any
Multi-Arch: no
Section: libdevel
Depends: libsquirrel3-0 (= ${binary:Version}),
         ${misc:Depends}
Description: development files for the Squirrel programming language
 Squirrel is a high-level imperative, object-oriented programming
 language, designed to be a lightweight scripting language that fits
 in the size, memory bandwidth, and real-time requirements of
 applications like video games.
 .
 This package contains developer resources for using the Squirrel
 library. Install it if you are developing programs that use the
 Squirrel API.