File: info.html

package info (click to toggle)
squishdot 1.3.0-1
  • links: PTS
  • area: main
  • in suites: woody
  • size: 896 kB
  • ctags: 349
  • sloc: python: 2,313; makefile: 56; sh: 54
file content (179 lines) | stat: -rw-r--r-- 6,509 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
<HTML>
<HEAD>
<base href="http://www.squishdot.org/Download/Documentation/upgrades.html/" />

<title>Squishdot Documentation</title>
</HEAD>
<body text="000000" bgcolor="#F4F4F4" link="0066cc" vlink="006666">
<basefont face="times" size="3">

<center>
<table border="0" cellspacing="2" cellpadding="8" width="99%">
    <tr>
	 <td width="15%"></td>
	 <td witdth="85%"></td>
	 </tr>
    <tr>
      <td colspan=2 align="center">
<a href="/"><img src="../Images/squishbanner.gif" alt="Squishdot banner" border="0"></a>
      </td>
    </tr>
    <tr>
    <td colspan=2><b><font color="000000" face="times" size="6">Squishdot Documentation</font></b></td>
    </tr>
    <tr>	  
      <td rowspan="10" valign="top">
<font size="2" face="arial,helvetica,times">
<b>Sections</b>

<li><A href="/">Home</A></li>
<li><A href="#intro">Introduction</A></li>
<li><A href="#features">Features</A></li>
<li><A href="../Download">Download</A></li>
<li><A href="#install">Installation</A></li>
<li> <A href="Security.html">Security</A></li>
<LI> <a href="upgrades.html">Upgrade Notes</a>
<li><A href="#support">Support</A></li>
<li><A href="../Subscribe">Mailing List</A></li>
<li><A href="#versions">Squishdot Versioning</A></li>
<LI> <a href="Changes">Changes</a>
<LI> <a href="Credits">Credits</a>
<LI> <a href="License">License</a>
</font>
</td>
 <td>
<h2> Upgrading to Squishdot 1.0.0 </h2>
<p>  <em>For details of using Updaters, see the README.TXT file in the Updaters folder of the Squishdot 1.0.0 distribution.</em></p>

<ul><li><p>Run the 0-7-x_1-0-0.py updater.</p>

</li>
<li><p>Replace the contents of the <code>mail_html</code> dtml method with the contents of the following:</p>
<ul><li><p><a href="mail_html.txt">mail_html</a></p>

</li></ul>

</li></ul>
<h3>Upgrading to Squishdot 0.7.x</h3>
<p>  There's a small change you need to make in the following DTML methods of each pre-0.7.0 Squishdot Site object:</p>

<ul><li><p><code>posting_html</code></p>

</li>
<li><p><code>previewPosting</code></p>

</li>
<li><p><code>addPostingForm</code></p>

</li></ul>
<p>  Whenever the expression <code>&lt;dtml-var expr="thread[0]" ></code> occurs, you need to replace it with <code>&lt;dtml-var expr="getThread(0)" ></code></p>

<p>  If you start getting KeyErrors on thread_path, it might be worth clicking on <code>Re-Catalog All Postings</code> on the <code>Options</code> manage tab.</p>


<h3>Upgrading to Squishdot 0.6.0</h3>
<p>  Assuming you are upgrading from 0.5.0, there's nothing you need to do to old Squishdot Sites!</p>


<h3>Upgrading to Squishdot 0.5.0</h3>
<p>  Assuming you are upgrading from 0.4.1, you don't <em>need</em> to do anything...</p>

<p>  However, if you want to use the new Plain Text and Structured Text stuff, 
  you'll need to change any exisiting Squishdot Sites you have as follows:</p>

<ul><li><p>Replace all occurence of <code>&lt;dtml-if body>&lt;dtml-in body>&lt;dtml-var sequence-item>&lt;/dtml-in body>&lt;/dtml-if body></code></p>
<p>    (or similar such things)</p>

<p>    with</p>

<p>    <code>&lt;dtml-var showBody></code></p>


</li>
<li><p>Replace all occurence of <code>&lt;dtml-if summary>&lt;dtml-in summary>&lt;dtml-var sequence-item>&lt;/dtml-in summary>&lt;/dtml-if summary></code></p>
<p>    (or similar such things)</p>

<p>    with</p>

<p>    <code>&lt;dtml-var showSummary></code></p>


</li>
<li><p>Add the following in the appropriate places on your <code>addPostingForm</code> method:</p>

</li></ul>

<p><PRE>
    &lt;SELECT NAME="encoding">       
    &lt;dtml-in "[['HTML','HTML'],['STX','Structured Text'],['Plain','Plain Text']]" >  
      &lt;OPTION VALUE="<dtml-var "_.getitem(<code>sequence-item</code>,0)[0]" html_quote>" &lt;dtml-if "encoding==_.getitem(<code>sequence-item</code>,0)[0]">SELECTED&lt;/dtml-if>>
      &lt;dtml-var "_.getitem(<code>sequence-item</code>,0)[1]" html_quote>
      &lt;/OPTION>
    &lt;/dtml-in>
    &lt;/SELECT>
</PRE></p>
<ul><li><p>Add the following in the appropriate places on your <code>previewPosting</code> method:</p>

</li></ul>

<p><PRE>
    &lt;SELECT NAME="encoding">       
     &lt;dtml-in "[['HTML','HTML'],['STX','Structured Text'],['Plain','Plain Text']]" >  
       &lt;OPTION VALUE="&lt;dtml-var "_.getitem(<code>sequence-item</code>,0)[0]" html_quote>" &lt;dtml-if "REQUEST.get(<code>encoding</code>,'HTML')==_.getitem(<code>sequence-item</code>,0)[0]">SELECTED&lt;/dtml-if>>
       &lt;dtml-var "_.getitem(<code>sequence-item</code>,0)[1]" html_quote>
       &lt;/OPTION>
     &lt;/dtml-in>
    &lt;/SELECT>
</PRE></p>
<ul><li><p>Finally, add the following to the form in the <code>showError</code> method:</p>
<p>    &lt;INPUT TYPE="HIDDEN" NAME="encoding" VALUE="&lt;dtml-var "REQUEST['encoding']" html_quote missing>"></p>


</li></ul>

<h3>Upgrading to Squishdot 0.4.1</h3>
<p>  Assuming you are upgrading from 0.4.0, please do the following for each of your Squishdot objects:</p>

<ul><li><p>change the two calls to showError in the <code>previewPosting</code> dtml method so they start start "showError(<code>_</code>.None,_,title" instead of "showError(REQUEST=REQUEST,title".</p>

</li>
<li><p>you may also wish to create a new <code>Plain</code> demo site and copy mail_html and addPostingForm to replace those in any Squishdot objects created by a pre-0.4.1 version of Squishdot.</p>

</li></ul>

<h3>Upgrading to Squishdot 0.4.0</h3>
<p>  If you are upgrading from a previous version of Squishdot to 0.4.0, please do the following for each of your Squishdot objects:</p>

<ul><li><p>Rename the <code>searchResults</code> dtml method to <code>showSearchResults</code>.</p>

</li>
<li><p>In the <code>Postings</code> management tab, click on
    <code>Update Indexing</code>.</p>

</li>
<li><p><em>As an alternative to the above two steps, use the 0-3-x_0-4-x.py updater</em></p>

</li>
<li><p>Replace the contents of the <code>mail_html</code> dtml method with the contents of either of the following:</p>
<ul><li><p><a href="plain.txt">Plain</a> text mail notification.</p>

</li>
<li><p><a href="mime.txt">MIME</a> encoded mail notifcation.</p>

</li></ul>

</li></ul>
<p>
<TABLE BORDER=1 CELLPADDING=2>
</TABLE></p>



       </td>
    </tr>
</table>
<a href="http://www.zope.org/Credits" target="_top"><img src="http://www.squishdot.org/p_/ZopeButton" width="115" height="50" border="0" alt="Powered by Zope"></a>
&nbsp;&nbsp;<a href="http://squishdot.org"><img src="../Images/squishlogo" alt="Squishdot Powered" border=1 WIDTH="75" HEIGHT="50"></a> 
</center>
</body>
</html>