File: changelog

package info (click to toggle)
sra-sdk 2.10.9+dfsg-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 38,576 kB
  • sloc: ansic: 211,129; cpp: 54,855; perl: 7,788; sh: 6,988; makefile: 5,174; python: 3,840; java: 2,363; yacc: 786; lex: 416; ruby: 329; lisp: 268; xml: 55
file content (353 lines) | stat: -rw-r--r-- 12,500 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
sra-sdk (2.10.9+dfsg-2) unstable; urgency=medium

  * run-unit-test: Give up for now on {abi,fastq,illumina,sff}-load.
    All four rely deeply on retired VDB functionality that would be
    too awkward to reintroduce.
  * skip_broken_loaders.patch (new): Likewise stop building or trying to
    install anything from tools/sra-load, to avoid leading users on.

 -- Aaron M. Ucko <ucko@debian.org>  Thu, 04 Feb 2021 20:38:51 -0500

sra-sdk (2.10.9+dfsg-1) unstable; urgency=medium

  * New upstream version
  * Standards-Version: 4.5.1 (routine-update)
  * debhelper-compat 13 (routine-update)
  * d/watch:
    - file standard 4
    - Use filemangle to make sure the archive will not mixed up
      with other ncbi code with same version
  * Remove default debian/gbp.conf
  * Bump versioned Build-Depends: libngs-sdk-dev (>= 2.10.9)
  * Drop patch reenable_legacy_schema_in_sra_load.patch

 -- Andreas Tille <tille@debian.org>  Mon, 18 Jan 2021 09:23:28 +0100

sra-sdk (2.10.7+dfsg-1) unstable; urgency=medium

  * New upstream version
  * Trim trailing whitespace.
  * Set field Upstream-Contact in debian/copyright.
  * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
    Repository-Browse.
  * Remove obsolete field Contact from debian/upstream/metadata (already present
    in machine-readable debian/copyright).

 -- Aaron M. Ucko <ucko@debian.org>  Tue, 02 Jun 2020 21:47:38 -0400

sra-sdk (2.10.6+dfsg-5) unstable; urgency=medium

  * debian/patches/reenable_legacy_schema_in_sra_load.patch: New patch to
    make use of ncbi-vdb's new SRAUseLegacyDefaultSchema toggle,
    unbreaking tools/sra-load (fastq-load et al.)  (Closes: #961347.)
  * debian/control: Ensure that this toggle is available at build time and
    at runtime.

 -- Aaron M. Ucko <ucko@debian.org>  Mon, 25 May 2020 22:45:07 -0400

sra-sdk (2.10.6+dfsg-4) unstable; urgency=medium

  * Account for new sratools setup.  (Closes: #961256.)
    - debian/rules: Rework deversioning logic to account for sratools and
      *-orig.* while still keeping hardcoding to a minimum; formally
      supply a hardcoded but originally random standard installation ID in
      a new /etc/ncbi/debian.kfg.
    - debian/patches/use_unversioned_tools.patch (new): Have sratools look
      for executable names without version extensions.

 -- Aaron M. Ucko <ucko@debian.org>  Fri, 22 May 2020 09:25:13 -0400

sra-sdk (2.10.6+dfsg-3) unstable; urgency=medium

  * Also exclude sra-pileup check_skiplist test per network access.

 -- Aaron M. Ucko <ucko@debian.org>  Thu, 21 May 2020 10:17:04 -0400

sra-sdk (2.10.6+dfsg-2) unstable; urgency=medium

  * drop_tests.patch: Exclude kar (needs network access); retire
    test-vdb-config exclusion with (fake)root out of the picture.
    Update description accordingly.
  * ignore_failing_test_for_the_moment_FIXME.patch: Resync.

 -- Aaron M. Ucko <ucko@debian.org>  Thu, 21 May 2020 09:03:42 -0400

sra-sdk (2.10.6+dfsg-1) unstable; urgency=medium

  [ Steffen Moeller ]
  * New upstream version
  * debhelper-compat 12
  * Standards-Version: 4.4.1

  * ncbi-vdb needs to appear as 2.10.2 in Debian with its mbedtls wrapper
    fixed to avoid a link error in this package.

  [ Michael R. Crusoe ]
  * Convert to Python3. Closes: #943231
  * Standards-Version: 4.5.0 (routine-update)

  [ Aaron M. Ucko ]
  * Correct accidental cutover to ncbi-vdb 2.10.5(+dfsg); further update to
    2.10.6.
  * Revert patch updates contingent on spurious cutover to ncbi-vdb.
  * Refresh patches for real.
    - Generally standardize on -pab format.
    - hardening.patch: Rebase C(P)FLAGS, which no longer request extensions.
    - python3: Drop makefile tweaks obsoleted by new PYTHON abstraction.
  * Help validate-names4.c find ncbi-vdb headers that are normally internal.
    To wit, build-depend on libncbi-vdb-dev (>= 2.10.6+dfsg-2~) to ensure
    these headers are installed sanely, and patch validate-names4.c
    accordingly in a new patch use_exposed_headers.patch.  In conjunction
    with taking the latest upstream, closes: #961049.
  * Specify configuration location by passing KONFIG_DIR.  (The makefile
    patch previously in use relied on [fake]root.)
  * Fix usage of default Debian build flags: Use buildflags.mk with
    appropriate _APPEND settings, and tweak hardening.patch to add
    DEB_*FLAGS to the front rather than the end (so as to keep upstream's
    preferred optimization level).
  * Preclean more fully to allow for consecutive builds.
  * List (wildcard) currently uninstalled files in debian/not-installed.
  * Correct logic for identifying all failing tests when there are any.
  * Secure URI in copyright format (routine-update)
  * Respect DEB_BUILD_OPTIONS in override_dh_auto_test target (routine-
    update)
  * Remove trailing whitespace in debian/changelog (routine-update)
  * Remove trailing whitespace in debian/rules (routine-update)
  * Add salsa-ci file (routine-update)
  * Rules-Requires-Root: no (routine-update)
  * Add myself to uploaders.

 -- Aaron M. Ucko <ucko@debian.org>  Wed, 20 May 2020 22:15:19 -0400

sra-sdk (2.9.4+dfsg-1) unstable; urgency=medium

  * Team upload.

  * New upstream version.
  * Bumped policy to 4.3.0

 -- Steffen Moeller <moeller@debian.org>  Tue, 26 Feb 2019 15:01:51 +0100

sra-sdk (2.9.3+dfsg-1) unstable; urgency=medium

  * Team upload.

  * New upstream version.

 -- Steffen Moeller <moeller@debian.org>  Tue, 23 Oct 2018 15:12:22 +0200

sra-sdk (2.9.2+dfsg-2) unstable; urgency=medium

  * Architecture: amd64

 -- Andreas Tille <tille@debian.org>  Fri, 14 Sep 2018 08:24:15 +0200

sra-sdk (2.9.2+dfsg-1) unstable; urgency=medium

  * New upstream version
  * Standards-Version: 4.2.1

 -- Andreas Tille <tille@debian.org>  Mon, 10 Sep 2018 08:25:37 +0200

sra-sdk (2.9.1-1+dfsg-2) unstable; urgency=medium

  * Team upload.
  * Set Build-Depends: libncbi-vdb-dev (>=2.9.1) to avoid undefined symbol
    errors

 -- Liubov Chuprikova <chuprikovalv@gmail.com>  Thu, 05 Jul 2018 19:13:15 +0300

sra-sdk (2.9.1-1+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Andreas Tille ]
  * New upstream version
  * debhelper 11
  * New Build-Depends: libvdb-sqlite-dev, versioned Build-Depends
    libncbi-vdb-dev (>= 2.9.0)
  * Exclude strangely failing test align-cache (needs investigation)

  [ Liubov Chuprikova ]
  * Add autopkgtest
  * Point Vcs fields to salsa.debian.org
  * Standards-Version: 4.1.4

 -- Liubov Chuprikova <chuprikovalv@gmail.com>  Sun, 01 Jul 2018 08:22:54 +0200

sra-sdk (2.8.2-5+dfsg-1) unstable; urgency=medium

  * New upstream version
  * Standards-Version: 4.1.3

 -- Andreas Tille <tille@debian.org>  Sun, 18 Feb 2018 15:44:10 +0100

sra-sdk (2.8.2-3+dfsg-1) unstable; urgency=medium

  [ Steffen Moeller ]
  * debian/upstream/metadata:
    - added references to registries
    - yamllint cleanliness

  [ Andreas Tille ]
  * New upstream version
  * cme fix dpkg-control
  * Standards-Version: 4.1.1
  * debhelper 10
  * renamed function to resolve name clash with gnutards to avoid
    FTBFS with glibc 2.25
    Closes: #882349
  * Drop test that should not run as root

 -- Andreas Tille <tille@debian.org>  Mon, 04 Dec 2017 08:29:02 +0100

sra-sdk (2.8.1-2+dfsg-2) unstable; urgency=medium

  * Fix install dir by using DEB_HOST_MULTIARCH instead of DEB_BUILD_GNU_TYPE
    (thanks for the patch to Graham Inggs <ginggs@debian.org>)
    Closes: #859261

 -- Andreas Tille <tille@debian.org>  Sat, 01 Apr 2017 23:06:00 +0200

sra-sdk (2.8.1-2+dfsg-1) unstable; urgency=medium

  * New upstream bugfix release

 -- Andreas Tille <tille@debian.org>  Tue, 24 Jan 2017 09:05:43 +0100

sra-sdk (2.8.1+dfsg-3) unstable; urgency=medium

  * Upstream suggested a different name to resolve #851219: vdb-get

 -- Andreas Tille <tille@debian.org>  Sat, 14 Jan 2017 14:41:57 +0100

sra-sdk (2.8.1+dfsg-2) unstable; urgency=medium

  * Deal with name space conflict with kget
    Closes: #851219

 -- Andreas Tille <tille@debian.org>  Fri, 13 Jan 2017 09:23:03 +0100

sra-sdk (2.8.1+dfsg-1) unstable; urgency=medium

  * New upstream version
    Closes: #846461
  * For whatever reason configure is checking for libfuse-dev so add it to
    Build-Depends
  * Build-Depends: libhdf5-dev, libmagic-dev, libxml2-dev

 -- Andreas Tille <tille@debian.org>  Wed, 11 Jan 2017 23:06:42 +0100

sra-sdk (2.7.0-2) unstable; urgency=medium

  * d/rules: Remove -pie to adapt to latest changes in dpkg
  * link against Debian packaged libmbedtls-dev
  * Enable build using ncbi-vdb version 2.8.0

 -- Andreas Tille <tille@debian.org>  Fri, 25 Nov 2016 19:08:25 +0100

sra-sdk (2.7.0-1) unstable; urgency=medium

  [ Andreas Tille ]
  * New upstream version
    Closes: #680436, #769050
  * d/watch points to github
  * d/copyright: no need to exclude any files any more
  * cme fix dpkg-control
  * New Build-Depends: libhdf5-dev, libngs-sdk-dev (>= 1.2.4)
  * drop library packages since these are now build by ncbi-vdb
  * use Github as homepage

  [ Steffen Moeller and Jon Ison ]
  * Introduced EDAM annotation to debian/upstream/edam

 -- Andreas Tille <tille@debian.org>  Thu, 01 Sep 2016 15:41:02 +0200

sra-sdk (2.3.5-2+dfsg-1) unstable; urgency=medium

  * New upstream version
  * d/rules: Adapt get-orig-source target to new uscan implementation
  * d/watch: use uversionmangle to get properly named download tarball

 -- Andreas Tille <tille@debian.org>  Wed, 30 Jul 2014 13:52:45 +0200

sra-sdk (2.3.4-2+dfsg-2) unstable; urgency=medium

  * delete symbols file
    Closes: #736411
  * lintian override for no-symbols-control-file

 -- Andreas Tille <tille@debian.org>  Thu, 23 Jan 2014 13:41:59 +0100

sra-sdk (2.3.4-2+dfsg-1) unstable; urgency=medium

  * New upstream version
  * debian/control:
     - Add missing Depends: sra-toolkit-libs0 to sra-toolkit-libs-dev
       Closes: #715133
     - Standards-Version: 3.9.5 (no changes needed)
  * debian/sra-toolkit-libs0.symbols: Adapted to new upstream version

 -- Andreas Tille <tille@debian.org>  Mon, 23 Dec 2013 22:27:00 +0100

sra-sdk (2.3.3-4~dfsg-1) unstable; urgency=low

  [ Andreas Tille ]
  * New upstream version
  * debian/upstream: Add citation information
  * fix debian/watch
  * debian/control:
     - cme fix dpkg-control
     - debhelper 9
     - canonical Vcs fields
  * debian/copyright: Exclude external libraries
  * debian/rules:
     - Add get-orig-source target to call enhances uscan
     - remove override because upstream seems to do the correct thing now
     - libsra-schema seems to be not built any more in this version so
       drop the special handling of it
     - Reactivate deletion of libs/krypto/*.pic.o.list files to get a
       really clean source
  * debian/doc: USAGE is not provided by upstream any more
  * debian/patches/build-with-system-libbz2-libz.patch: Fix build problem
    (thanks to Gert Wollny <gw.fossdev@gmail.com> for the patch)
  * debian/sra-toolkit.install: There are neither mod?? nor wmod?? files
    shipped in this version any more - so remove these from dh_install
  * debian/patches/hardening.patch: Propagate Debian hardening options
    into build system
  * debian/patches/hardening-format-security.patch: Fix format strings in
    snprintf() calls
  * debian/watch: mangle version string
  * debian/sra-toolkit-libs0.lintian-overrides: override
    package-name-doesnt-match-sonames

  [ Charles Plessy ]
  32dd5cd Updated symbols file.

 -- Andreas Tille <tille@debian.org>  Wed, 23 Oct 2013 10:43:20 +0200

sra-sdk (2.1.7a-1) unstable; urgency=low

  [ Charles Plessy ]
  61e22aa New upstream release (Closes: #627861).
  1b09fd5 Normalised debian/copyright file with config-edit.
  a93e7b5 Wildcard characters to match 64 or 32 according to the architecture.
  3d66d80 New upstream source location in debian/watch.
  74e5234 Mark the use of git-buildpackage by debian/gbp.conf.
  0074d68 Simplified Homepage URL in debian/control.
  5cd8039 Use a target that allows dynamic linking (debian/rules).
  9815817 Do not install empty /usr/bin/ncbi directory (debian/rules).
  fb42792 Updated debian/sra-toolkit-libs0.symbols.
  866f773 Install config.kfg and vdb-copy.kfg in /etc/ncbi.

  [ Andreas Tille ]
  9e6e831 Suggest patches for build system to build on non i386&amd64
    architectures as well as BSD and Hurd

 -- Charles Plessy <plessy@debian.org>  Tue, 10 Jan 2012 09:06:14 +0900

sra-sdk (2.0.1-1) unstable; urgency=low

  * Initial release (Closes: #610603).

 -- Charles Plessy <plessy@debian.org>  Tue, 24 May 2011 14:48:10 +0900