File: changelog

package info (click to toggle)
stalin 0.11-6
  • links: PTS
  • area: main
  • in suites: bullseye, buster, sid, stretch
  • size: 110,396 kB
  • ctags: 163,122
  • sloc: ansic: 1,757,574; lisp: 88,332; sh: 1,514; makefile: 229; sed: 100; csh: 30
file content (245 lines) | stat: -rw-r--r-- 8,161 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
stalin (0.11-6) unstable; urgency=medium

  [ Rob Browning ]
  * Move debian/.gitignore to ./ and add /.pc.
  * Move prebuilt ./stalin-arch-*.c files to debian/prebuilt-src/.

  [ Barak A. Pearlmutter ]
  * Remove obsolete debian/prerm.
  * Update depends, standards-version, section, priority, and homepage.
  * Expand copyright information and update for 0.11.
  * Add uscan support (debian/watch).
  * Switch to "3.0 (quilt)" source format.

  [ Rob Browning ]
  * Simplify override_dh_testdir since entire tree is now in git.
  * Update FSF address in debian/copyright.
  * Don't use debian/clean since it can't handle directories.
  * Switch to git-dpm.
  * Don't build/use the local libgc. (Closes: 778130)
  * Remove quilt build dependency.

 -- Rob Browning <rlb@defaultvalue.org>  Sat, 27 Jun 2015 11:34:59 -0500

stalin (0.11-5) unstable; urgency=low

  * Build with debugging information (gcc -g).

  * Remove build dependency on build-essential dpkg-dev package.
    Thanks to Manoj Srivastava <srivasta@debian.org> for the report.
    (closes: #553474)

  * Switch to debhelper which should fix issues with quilt and the clean
    target.  Thanks to Raphael Hertzog <hertzog@debian.org> for the
    report. (closes: 484910)

 -- Rob Browning <rlb@defaultvalue.org>  Sat, 31 Oct 2009 16:08:15 -0700

stalin (0.11-4) unstable; urgency=low

  * Really fix support for GNU/kFreeBSD.  Thanks again to Petr Salinger.
    (closes: #410810)

 -- Rob Browning <rlb@defaultvalue.org>  Fri,  2 Mar 2007 17:38:34 -0800

stalin (0.11-3) unstable; urgency=low

  * Turn off optimization on amd64 in order to be able to build within 2GB
    (hopefully).  (closes: #404734)

  * Fix support for GNU/kFreeBSD.  Thanks to Petr Salinger.
    (closes: #410810)

 -- Rob Browning <rlb@defaultvalue.org>  Sun, 25 Feb 2007 13:46:35 -0800

stalin (0.11-2) unstable; urgency=low

  * Add kfreebsd-i386 and kfreebsd-amd64 to the architectures list.
    (closes: #314857)

  * Add real package alternatives for all of the virtual build
    dependencies.  (closes: #409450)

  * Use stalin's internal copy of libgc for now.  Debian's doesn't build
    with the same options (gc-Makefile.sed) and runs out of RAM during a
    bootstrap build.

  * Try using -O1 on amd64 to reduce memory usage.  Apparently -O2
    wouldn't build on a 2GB machine (see bug #404734).

 -- Rob Browning <rlb@defaultvalue.org>  Sun,  4 Feb 2007 11:29:45 -0800

stalin (0.11-1) unstable; urgency=medium

  * Migrate to a new upstream release; This should resolve the licensing
    issues with the opengl/xlib bindings. (closes: #375943)

  * Remove dependency on gcc-3.4.  The bug in gcc-4.1 has been fixed, and
    gcc-4.0 should work correctly as well.

  * Add dependencies on dpkg-dev; stalin-architecture-name uses it now.

  * Add support for ia64 and amd64.

  * Generate new precompiled C source for all architectures. (closes: #337169)

  * Drop support for m68k and arm since, if nothing else, their buildds
    don't have enough RAM.  For the same reason, don't add powerpc.
    (closes: #271836, #273130)

  * Change xlibs-dev dependency to libx11-dev. (closes: #347053)

  * Add build-time support for selection of scheme compiler,
    i.e. "stalin=./stalin ./build"

  * Change upstream gcc -O3 to -O2; -O3 requires much more RAM.

  * Generalize makefile architecture support (i.e. stalin-arch-%.c) and
    add all-precompiled-srcs target.

  * Test the build by running some benchmarks afterward.

  * Invoke benchmarks/make-clean from "make clean".

  * Drop stalin-wrapper; stalin itself handles things now.

 -- Rob Browning <rlb@defaultvalue.org>  Sun, 12 Nov 2006 22:47:26 -0800

stalin (0.9+0.10alpha2-2) unstable; urgency=low

  * Migrate to quilt.

  * Fix problem where bootstrap required . to be in PATH.  Thanks to
    Christopher Cramer.  (closes: #336502)
    - debian/patches/misc.diff.
  
  * Rebuild against newer libgc.  (closes: #320972, #324498)

  * Build-Depend on and build with gcc-3.4 for now.  A gcc-4.0 build goes
    off into an infinite loop at the moment.  The compiler can now be
    selected via the CC environment variable.
    - debian/patches/allow-compiler-selection.diff
    - debian/control
    - debian/rules

  * Add simple after-build sanity checks.
    - debian/rules

 -- Rob Browning <rlb@defaultvalue.org>  Sun, 30 Oct 2005 15:48:21 -0800

stalin (0.9+0.10alpha2-1) unstable; urgency=medium

  * New release (0.10alpha2) that the upstream author has requested we use
    in place of 0.9.
  * Save space by just making symbolic links for several platforms that
    need the same C code as stalin-IA32.c.  (closes: #231602)
    - debian/rules
  * Remove alpha from Architecture since it was never supposed to be there
    and the package is known (upstream) not to work there yet.  (closes:
    #216341).
    - debian/control

 -- Rob Browning <rlb@defaultvalue.org>  Tue, 17 Aug 2004 17:05:12 -0500

stalin (0.9-4) unstable; urgency=low

  * move to libgc1.

 -- Rob Browning <rlb@defaultvalue.org>  Wed, 20 Aug 2003 08:52:31 -0500

stalin (0.9-3) unstable; urgency=low

  * recompile to pick up new libgc6 revision. (closes: #178366)
  * don't add /usr/share/doc/ symlink in postinst.
  * fix spelling error in description.

 -- Rob Browning <rlb@defaultvalue.org>  Sun, 26 Jan 2003 13:49:56 -0600

stalin (0.9-2) unstable; urgency=high

  * Use the architecture field to list the archs that stalin
    supports. (closes: #119735, #120206)

 -- Rob Browning <rlb@defaultvalue.org>  Thu,  6 Dec 2001 11:51:55 -0600

stalin (0.9-1) unstable; urgency=low

  * New upstream version.
  * Updated to latest upstream release. (closes: #97884)
  * Presumed stalin-ia32.c may work on arm and m68k since it's the
    replacement for stalin-32.c.  We'll find out when the autobuild
    daemons get hold of this.

 -- Rob Browning <rlb@defaultvalue.org>  Sun, 23 Sep 2001 10:58:12 -0500

stalin (0.8-10) unstable; urgency=low

  * Add m68k/Linux in ./build.  Thanks to Rick Younie.  (closes: #107648)
  * Change to depend on libgc6-dev instead of libgc5-dev.

 -- Rob Browning <rlb@defaultvalue.org>  Fri,  7 Sep 2001 13:05:52 -0500

stalin (0.8-9) unstable; urgency=medium

  * Add build-depends. (closes: #105867)

 -- Rob Browning <rlb@defaultvalue.org>  Thu, 19 Jul 2001 09:38:04 -0500

stalin (0.8-8) unstable; urgency=low

  * Update my email address (will package new version soon).
  * Strip binaries Debian-style.

 -- Rob Browning <rlb@defaultvalue.org>  Tue, 17 Jul 2001 13:49:24 -0500

stalin (0.8-7) unstable; urgency=low

  * change to */share/* from /usr (docs manpages etc).
  * fix handling of /usr/doc -> /usr/share/doc symlink in control scripts.
  * added tiny patck to build to fix arm compiles.  Thanks to
    <Philip.Blundell@pobox.com> (Closes: Bug#58111).
  * fixed hurd unfriendliness in debian/rules.  Thanks to
    Marcus.Brinkmann@ruhr-uni-bochum.de (Closes: Bug#54582).
  * changed location of GPL in copyright file.

 -- Rob Browning <rlb@cs.utexas.edu>  Sun, 24 Dec 2000 00:34:30 -0600

stalin (0.8-6) unstable; urgency=low

  * If you forget to use -On, Stalin now outputs a warning that the
    current version requires it (Closes: Bug#42387).

 -- Rob Browning <rlb@cs.utexas.edu>  Thu, 28 Oct 1999 00:24:43 -0500

stalin (0.8-5) unstable; urgency=low

  * Add patch for sparc compile (Closes: Bug#41073).
  * Switch to depend on libgc5-dev.

 -- Rob Browning <rlb@cs.utexas.edu>  Mon,  4 Oct 1999 23:43:29 -0500

stalin (0.8-4) unstable; urgency=low

  * Add dependency on libgc4-dev (Closes: Bug#39178)

 -- Rob Browning <rlb@cs.utexas.edu>  Fri, 11 Jun 1999 14:23:28 -0500

stalin (0.8-3) unstable; urgency=low

  * Spell checked the control file.
  * Fixed minor problem with compile-time includes
    (needed -copt -I -copt /usr/include/gc).

 -- Rob Browning <rlb@cs.utexas.edu>  Thu, 10 Jun 1999 14:16:45 -0500

stalin (0.8-2) unstable; urgency=low

  * Minor patch from author for problem in make-xhello.

 -- Rob Browning <rlb@cs.utexas.edu>  Wed,  2 Jun 1999 16:25:33 -0500

stalin (0.8-1) unstable; urgency=low

  * Initial release.

 -- Rob Browning <rlb@cs.utexas.edu>  Wed, 26 May 1999 18:11:43 -0500