1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157
|
From: Ole Streicher <olebole@debian.org>
Date: Wed, 12 Apr 2017 16:44:48 +0200
Subject: Fix build.xml for use outside of starjava
build.xml | 56 +++++++++++++++++++++++++-------------------------------
1 file changed, 25 insertions(+), 31 deletions(-)
diff --git a/build.xml b/build.xml
index 70a9ae7..265b070 100644
@@ -32,12 +32,6 @@
!-->
<project name="Build file for CDF" default="build" basedir=".">
-
- <!-- If either or both of these files exist then any properties
- ! contained within them will override those defined here. -->
- <property file="${user.home}/.stardev.properties"/>
- <property file=".properties"/>
-
<!-- Properties will also be set for all environment variables
! (PATH becomes "env.PATH"), generally not a good
! idea as names are OS dependent -->
@@ -50,13 +44,13 @@
!-->
<!-- Directory for the Starlink installation (usually /star/java)-->
- <property name="star.dir" value="${basedir}/../../"/>
+ <property name="star.dir" value="/usr/share/java"/>
<!-- Directory to install into (install target, usually /star/java)-->
<property name="star.install" value="${star.dir}"/>
<!-- Directory that contains the Starlink jar tree -->
- <property name="star.jar.dir" value="${star.dir}/lib"/>
+ <property name="star.jar.dir" value="${star.dir}"/>
<!-- Directory that contains the locally built sources (usually
! /star/java/source for full distribution) -->
@@ -77,8 +71,8 @@
!-->
<!-- Define the package name and current versions -->
- <property name="Name" value="CDF"/>
- <property name="name" value="cdf"/>
+ <property name="Name" value="Starjava CDF"/>
+ <property name="name" value="starlink-cdf"/>
<property name="version" value="1.0"/>
<!-- The Java package name -->
@@ -114,6 +108,7 @@
<!-- Directory containing any third-party jars that should be
! distributed (normally these would belong in a proper package)-->
<property name="src.jars.dir" value="${src.dir}/lib"/>
+ <mkdir dir="${src.jars.dir}"/>
<!-- Directory containing any JNI source code -->
<property name="src.jni.dir" value="${src.dir}/jni"/>
@@ -196,21 +191,23 @@
! 1.4 is no longer used the extclasspath type can be replaced by a simple
! path.
!-->
- <extclasspath id="installed.classpath">
-
- <!-- Table -->
- <pathelement location="${star.jar.dir}/table/table.jar"/>
+ <path id="installed.classpath">
+ <pathelement location="${star.jar.dir}/starlink-table.jar"/>
+ <pathelement location="${star.jar.dir}/jcdf.jar"/>
+ <pathelement location="${star.jar.dir}/junit.jar"/>
+ </path>
- </extclasspath>
+ <path id="jar.classpath">
+ <pathelement location="${dist.lib.pkg}/starlink-table.jar"/>
+ <pathelement location="${dist.lib.pkg}/jcdf.jar"/>
+ </path>
<!-- Local build system jar files.
!
! Name all the jar files of other packages that we depend on, which have
! not been installed (should be same packages as in installed.classpath).
!-->
- <extclasspath id="built.jarpath">
- <pathelement location="${star.build.dir}/table/lib/table/table.jar"/>
- </extclasspath>
+ <path id="built.jarpath"/>
<!-- Find all local third party jars files.
!
@@ -303,6 +300,7 @@
<pathelement location="${tests.dir}"/>
<pathelement location="${tests.etc.dir}"/>
<path refid="classpath"/>
+ <pathelement location="${star.jar.dir}/${name}.jar"/>
</path>
<!-- Turn this path into a string which is passed to the tests -->
@@ -392,7 +390,8 @@
destdir="${build.classes}"
debug="${debug}"
deprecation="${deprecation}"
- source="${source.version}"
+ encoding="cp1252"
+ includeantruntime="false"
optimize="${optimize}">
<compilerarg value="-Xlint:all,-path,-serial"/>
@@ -443,6 +442,10 @@
description="-> creates the package jar file(s)">
<mkdir dir="${dist.lib.pkg}"/>
+ <manifestclasspath property="jar.class.path"
+ jarfile="${dist.lib.pkg}/${name}.jar">
+ <classpath refid="jar.classpath" />
+ </manifestclasspath>
<jar destfile="${dist.lib.pkg}/${name}.jar"
basedir="${build.classes}">
<manifest>
@@ -451,16 +454,6 @@
</manifest>
</jar>
- <!-- Sign all jar files -->
- <antcall target="signjars"/>
- </target>
-
- <target name="signjars" if="sign.jars">
- <signjar jar="${dist.lib.pkg}/${name}.jar"
- alias="${webstart.alias}"
- keystore="${webstart.keystore}"
- keypass="${webstart.keypass}"
- storepass="${webstart.storepass}"/>
</target>
<!--
@@ -889,7 +882,7 @@
windowtitle="${Name} API"
doctitle="${Name}"
defaultexcludes="yes"
- source="${source.version}"
+ encoding="cp1252"
classpathref="classpath">
<arg value="-Xdoclint:all,-missing"/>
<arg value="-quiet"/>
@@ -972,7 +965,8 @@
<javac srcdir="${tests.dir}"
destdir="${build.tests}"
debug="${debug}"
- source="${source.version}"
+ encoding="cp1252"
+ includeantruntime="false"
deprecation="${deprecation}" >
<classpath refid="tests-classpath"/>
|