1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84
|
CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
export QT_SELECT = qt5
config: config-stamp
config-stamp:
dh_testdir
touch $@
build-indep:
build-arch: build-stamp
build-stamp: config-stamp
dh_testdir
qmake -project \
-after "CONFIG+=opengl" -after "QT+=xml opengl script" -after "unix:LIBS+=-lGLU"
dh_auto_configure
$(MAKE) \
CFLAGS="$(CFLAGS) -fPIC -DDATADIR=\\\"/usr/share/structure-synth\\\"" \
CXXFLAGS="$(CXXFLAGS) $(CPPFLAGS) -fPIC -DDATADIR=\\\"/usr/share/structure-synth\\\"" \
LFLAGS="$(LDFLAGS) -Wl,-z,defs -Wl,-as-needed -Wl,--no-undefined" \
TARGET="structure-synth"
touch $@
build: build-indep build-arch
clean:
dh_testdir
dh_testroot
rm -f build-stamp config-stamp
test ! -e Makefile || $(MAKE) distclean \
TARGET="structure-synth"
rm -f *.pro .qmake.stash
dh_clean
install: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
$(MAKE) DESTDIR=$(CURDIR)/debian/structure-synth install
binary-indep: build install
binary-arch: build install
dh_testdir
dh_testroot
dh_installchangelogs changelog.txt
dh_installdocs
dh_installexamples
dh_install
dh_installman debian/structure-synth.1
dh_link
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
get-orig-source:
rm -f StructureSynth-Source-v1.0.0.zip
rm -rf "Structure Synth Source Code"
wget http://downloads.sourceforge.net/sourceforge/structuresynth/StructureSynth-Source-v1.0.0.zip?use_mirror=freefr
unzip StructureSynth-Source-v1.0.0.zip
rm StructureSynth-Source-v1.0.0.zip
rm -r "Structure Synth Source Code"/Build/*
rm -f ../structure-synth_1.0.0.orig.tar.gz
tar cvfz ../structure-synth_1.0.0.orig.tar.gz "Structure Synth Source Code"
rm -r "Structure Synth Source Code"
binary: binary-indep binary-arch
.PHONY: build-indep build-arch build clean binary-indep binary-arch binary install config
|