File: changelog

package info (click to toggle)
sugar-toolkit-gtk3 0.112-3
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 5,184 kB
  • sloc: python: 12,700; ansic: 8,195; sh: 4,241; makefile: 362
file content (361 lines) | stat: -rw-r--r-- 13,714 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
sugar-toolkit-gtk3 (0.112-3) unstable; urgency=medium

  * Add patch cherry-picked upstream
    to fix handle new OpenSSH DSA key format.
    Closes: Bug#928801.

 -- Jonas Smedegaard <dr@jones.dk>  Sat, 11 May 2019 13:58:36 +0200

sugar-toolkit-gtk3 (0.112-2) unstable; urgency=medium

  * Add 0001-sugar3.speech-remove-GConf-compatibility-support.patch
  * Drop unused gir1.2-gconf-2.0 dependency.
  * Update VCS URLs to match the repository in salsa.
  * debian/rules: override s/libfribidi0-dev/libfribidi-dev/ in
    d-shlibmove to address #895235
  * libsugarext-dbg: move Priority: extra to Priority: optional to follow
    Policy.
  * Declare compliance with Debian Policy 4.1.4.

 -- Santiago Ruano Rincón <santiago@debian.org>  Mon, 14 May 2018 14:14:11 +0200


sugar-toolkit-gtk3 (0.112-1) unstable; urgency=medium

  [ upstream ]
  * New release(s).

  * Update watch file: Use patterns.
  * Update git-buildpackage config: Stop set debian-branch.
  * Declare compliance with Debian Policy 4.1.1.
  * Drop patches cherry-picked upstream and since applied.
  * Add patch 1001 to handle voices from eSpeak NG.
  * Update package relations:
    + Fix have python-gtk3 recommend gstreamer1.0-espeak
      gstreamer1.0-plugins-good.
  * Unfuzz patches.
  * Handle upstream releases without micro version.
  * Fix rename locale ibo→ig (and not aym→ay no longer shipped
    upstream): ISO 639-1 favored over ISO 639-2.

 -- Jonas Smedegaard <dr@jones.dk>  Wed, 15 Nov 2017 03:09:10 +0100

sugar-toolkit-gtk3 (0.110.0-5) unstable; urgency=medium

  * Declare compliance with Debian Policy 4.1.0.
  * Update git-buildpackage config: Filter any .git* files.
  * Update watch file: Tighten version regex.
  * Modernize cdbs:
    + Drop upstream-tarball hints: Use gbp import-orig --uscan.
    + Do copyright-check in maintainer script (not during build).
      Relax to build-depend unversioned on cdbs.
      Stop build-depend on licensecheck.
  * Update copyright info:
    + Use https protocol in file format URL.
    + Use SPDX License shortnames FSFUL FSFULLR (and derived forms).
  * Tighten lintian overrides regarding License-Reference.

 -- Jonas Smedegaard <dr@jones.dk>  Wed, 30 Aug 2017 11:25:29 +0200

sugar-toolkit-gtk3 (0.110.0-4) unstable; urgency=medium

  * Add patch cherry-picked upstream to fix depend instead of append to
    path.
    Closes: Bug#860943. Thanks to James Cameron.

 -- Jonas Smedegaard <dr@jones.dk>  Sat, 22 Apr 2017 14:19:42 +0200

sugar-toolkit-gtk3 (0.110.0-3) unstable; urgency=medium

  * Add patch cherry-picked upstream to fix screen resize race.
  * Add patch cherry-picked upstream to sort translation files.
    Closes: Bug#848633. Thanks to Dhole.
  * Modernize Vcs-* fields:
    + Use https protocol.
    + Use git subdir (not cgit).
    + Add .git suffix for Vcs-Git URL.
  * Stop override lintian for
    package-needs-versioned-debhelper-build-depends: Fixed in lintian.
  * Update watch file:
    + Bump to version 4.
    + Mention gbp --uscan in usage comment.
  * Update copyright info: Extend coverage of Debian packaging.

 -- Jonas Smedegaard <dr@jones.dk>  Wed, 25 Jan 2017 04:28:26 +0100

sugar-toolkit-gtk3 (0.110.0-2) unstable; urgency=medium

  * Modernize CDBS use:
    + Let CDBS resolve if build is targeted experimental.
  * Update package relations:
    + Relax to recommend (not depend on) webkit/webkit2.
    + Favor webkit2 over webkit.
    + Recommend webkit2 (without webkit fallback) strengthen favoring.
    + Drop obsolete transitional conflicts/replaces/breaks.

 -- Jonas Smedegaard <dr@jones.dk>  Mon, 12 Dec 2016 19:00:52 +0100

sugar-toolkit-gtk3 (0.110.0-1) unstable; urgency=medium

  [ upstream ]
  * New release(s).
    Highlights:
    + Collaboration: Handle tubes channel failure gracefully.
    + Remove support for Rainbow.
    + Allow one to run activities without Sugar shell.

  [ Jonas Smedegaard ]
  * Update licensing info:
    + Fix add disclaimer to GAP License (arguably needs to be preserved
      as part of "this notice").
    + Extend coverage of autotools files.
    + Extend coverage of Debian packaging.
  * Declare compliance with Debian Policy 3.9.8.
  * Track only stable 0.110 branch in watch file.
  * Have git-buildpackage use versioned upstream branch.
  * Have python-sugar3 suggest python-jarabe and python-carquinyol.
  * Stop recommend older telepathy-gabble: No longer needed for
    collaboration.
  * Modernize CDBS use: Build-depend on licensecheck (not devscripts).
  * Unfuzz patch 2002.
  * Add patch cherry-picked upstream to fix avoid more introspection
    versioning warnings.
  * Use dh-autoreconf.
    + Build-depend on dh-autoreconf and autoconf-archive.
    Closes: Bug#744666. Thanks to Matthias Klose.

 -- Jonas Smedegaard <dr@jones.dk>  Mon, 12 Dec 2016 03:41:58 +0100

sugar-toolkit-gtk3 (0.106.1-1) unstable; urgency=medium

  [ upstream ]
  * New release.

  [ Jonas Smedegaard ]
  * Update licensing info:
    + Merge pseudo-derived licenses (Use License-Grant to indicate
      difference in verbatim text).

 -- Jonas Smedegaard <dr@jones.dk>  Mon, 14 Sep 2015 15:47:37 +0200

sugar-toolkit-gtk3 (0.106.0-1) unstable; urgency=medium

  [ upstream ]
  * New release.

 -- Jonas Smedegaard <dr@jones.dk>  Mon, 06 Jul 2015 19:53:05 -0500

sugar-toolkit-gtk3 (0.105.3-1) experimental; urgency=medium

  [ upstream ]
  * New release.

  [ Jonas Smedegaard ]
  (0.104.1-9 changes re-applied)

 -- Jonas Smedegaard <dr@jones.dk>  Thu, 02 Jul 2015 18:26:23 -0500

sugar-toolkit-gtk3 (0.105.2-1) experimental; urgency=medium

  [ upstream ]
  * New release(s).

  [ Jonas Smedegaard ]
  * Prepare for new major branch:
    + Switch packaging git branch.
    + Adapt watch file to track any branch.
  * Drop patch now included upstream, and unfuzz remaining patch.

 -- Jonas Smedegaard <dr@jones.dk>  Sun, 14 Jun 2015 15:29:45 -0500

sugar-toolkit-gtk3 (0.104.1-9) unstable; urgency=medium

  * Update package relations:
    + Favor Webkit over Webkit2: Webkit needed by Jarabe and Browse too.
    + Drop fallback-dependency on gir1.2-webkit2-3.0: Deprecated.
  * Relax watch file to cover any compression suffix.
  * Stop explicitly declare compression in git-buildpackage config.
  * Add lintian override regarding debhelper 9.
  * Fix rename locale aym→ay: ISO 639-1 favored over ISO 639-2.

 -- Jonas Smedegaard <dr@jones.dk>  Thu, 02 Jul 2015 17:05:44 -0500

sugar-toolkit-gtk3 (0.104.1-8) unstable; urgency=medium

  * Adapt packaging in maintainer mode when targeting experimental:
    + Switch git packaging branch.
    + Track any release (else only current branch).
  * Update package relations:
    + Relax to build-depend unversioned on libgirepository1.0-dev, and
      recommend unversioned telepathy-mission-control-5 and
      telepathy-salut: Needed versions satisfied even in oldstable.
    + Stop declare pre-dependency on multiarch-support: Handled by
      debhelper.
    + Tighten build-dependency on d-shlibs, and drop local overrides.
  * Stop manually remove .la file: Handled by d-shlibs.

 -- Jonas Smedegaard <dr@jones.dk>  Sat, 13 Jun 2015 16:42:47 -0500

sugar-toolkit-gtk3 (0.104.1-7) unstable; urgency=medium

  * Improve short descriptions.
  * Update package relations:
    + Relax to build-depend unversioned on debhelper: Version needed is
      satisfied even in oldstable.
  * Add patch cherry-picked upstream to avoid build MIME databases
    during upstream install routine.
    Closes: Bug#783890. Thanks to Martin Abente Lahaye.
  * Update copyright info:
    + Use License-Grant and License-Reference fields.
      Thanks to Ben Finney.
  * Add lintian overrides regarding license in License-Reference field.
    See bug#786450.
  * Modernize git-buildpackage config: Avoid "git-" prefix.

 -- Jonas Smedegaard <dr@jones.dk>  Sat, 30 May 2015 11:18:07 +0200

sugar-toolkit-gtk3 (0.104.1-6) unstable; urgency=medium

  * Fix use canonical URL in Vcs-Git field.
  * Update package relations:
    + Fix stop suggest subversion: Unused upstream since ~2008.
    + Fix explicitly recommend shared-mime-info.
  * Modernize long descriptions.

 -- Jonas Smedegaard <dr@jones.dk>  Mon, 20 Apr 2015 21:38:33 +0200

sugar-toolkit-gtk3 (0.104.1-5) unstable; urgency=medium

  * Move packaging to Debian Sugar Team.
  * Update package relations:
    + Fix depend on python-gi-cairo.
      Thanks to Martin Abente and James Cameron.
  * Fix typo in libsugarext-dev short description.
    Closes: bug#747026. Thanks to Anders Jonsson.

 -- Jonas Smedegaard <dr@jones.dk>  Fri, 17 Apr 2015 10:34:39 +0200

sugar-toolkit-gtk3 (0.104.1-4) experimental; urgency=medium

  * Fix Recommend telepathy-gabble-legacy or older telepathy-gabble (not
    recent telepathy-gabble): Old Tubes API needed.
    Thanks to Tincho.

 -- Jonas Smedegaard <dr@jones.dk>  Sat, 11 Apr 2015 03:08:09 +0200

sugar-toolkit-gtk3 (0.104.1-3) experimental; urgency=medium

  * Bump debhelper compatibility level to 9: Needed for multiarch-
    compatible debug files.
  * Update package relations:
    + Fix depend on python-decorator.
    + Recommend alsa-util to ensure audio devices are unmuted at boot
      (see bug#581504).
    + Fix suggest ipython.
    + Stop suggest ttf-dejavu-extra: Font handled by sugar-session-*.
    + Suggest git (not git-core).
    + Fix tighten python-sugar3 to depend on same source-version of
      gir1.2-sugarext-1.0, and tighten gir1.2-sugarext-1.0 to break
      older python-sugar3 depending too relaxed on its GIR.
      Thanks to James Cameron.
    + Tighten build-dependency on debhelper: Needed for tightened
      compatibility level.
    + Build-depend only (tightened) on python.dev (not python-all-dev):
      Sufficient for architecture-independent python build.
  * Declare dh_install arguments in rules (not *.install files).
  * Fix install GIR files into multiarch subdir.
  * Fix do hash-bang massage forward-compatible with cdbs 0.5.

 -- Jonas Smedegaard <dr@jones.dk>  Thu, 09 Apr 2015 18:17:22 +0200

sugar-toolkit-gtk3 (0.104.1-2) experimental; urgency=medium

  * Update package relations:
    + Fix have libsugarext-dev depend on auto-resolved *-dev packages.
    + Fix relax python-sugar3 to depend unversioned on gir* package.
    + Fix tighten gir1.2-sugarext-1.0 to depend versioned on
      libsugarext0: API is unstable.
  * Fix mark python-sugar3 as architecture-independent.

 -- Jonas Smedegaard <dr@jones.dk>  Sun, 05 Apr 2015 21:08:58 +0200

sugar-toolkit-gtk3 (0.104.1-1) experimental; urgency=medium

  * Update package relations:
    + Stop build-depend on libgconf2-dev or python-gtk2-dev.
    + Build-depend on libxfixes-dev.
    + Depend on and recommend gir1.2-webkit2-3.0 or gir1.2-webkit2-4.0,
      and recommend (but not depend on) gir1.2-webkit-3.0 as ultimate
      fallback.
    + Build-depend on linux-libc-dev or hurd-dev.
    + Have python-sugar3 depend on git1.2-atspi-2.0.
  * Update copyright info:
    + Merge Files sections with same license.
    + Fix list Files section with joker above */Makefile.in section, to
      not override.
    + Fix extend coverage for autotools.
    + Extend coverage for upstream authors.
  * Fix tell git-buildpackage to use xz compression.
  * Unfuzz patch 2002.
  * Disable patch 2003: Possibly obsoleted by recent upstream changes.
  * Use proper hash-bang in Python script (Python Policy 0.9 §3.1).
    Thanks to lintian.

 -- Jonas Smedegaard <dr@jones.dk>  Fri, 03 Apr 2015 20:36:09 +0200

sugar-toolkit-gtk3 (0.98.7-2) unstable; urgency=medium

  * Update copyright info:
    + Update alternate git source URL.
    + Extend coverage for myself, and relicense packaging as GPL-3+.
    + Fix use SPDX shortname for X11 license.
      Thanks to Paul Richards Tagliamonte.
    + Fix extend coverage for autotools.
    + Fix update and extend coverage for upstream authors.
    + Fix cover BSD-licensed src/sugar3/dispatch/*.
  * Bump dephelper compatibility level to 8.
  * Declare compliance with Debian Policy 3.9.6.
  * Update Vcs-Git field to use canonical URL.
  * Update Vcs-Browser field to use cgit and https.
  * Wrap Uploaders field.
  * Track xz compressed upstream tarballs (favored over bzip2).
  * Rewrite README.source to emphasize that control.in file is *not* a
    show-stopper for contributions, and refer to wiki page for details.
  * Unfuzz patch 2003.
  * Update package relations:
    + Fix have python-sugar3 depend on gir1.2-gconf-2.0, and stop
      build-depend explicitly on it.
    + Fix build-depend explicitly on libxi-dev: Needed by
      sugar-cursor-tracker, sugar-gesture-grabber and sugar-key-grabber.
    + Fix build-depend explicitly on libx11-dev and x11proto-core-dev:
      Needed by sugar-wm.

 -- Jonas Smedegaard <dr@jones.dk>  Fri, 03 Apr 2015 15:01:05 +0200

sugar-toolkit-gtk3 (0.98.7-1) unstable; urgency=low

  * New upstream release
  * Adding myself to Uploaders
  * Bump Standars-Version to 3.9.4

 -- Santiago Ruano Rincón <santiago@debian.org>  Sat, 07 Sep 2013 01:01:07 +0200

sugar-toolkit-gtk3 (0.96.1-2) unstable; urgency=low

  * Update package relations:
    + Fix build-depend on python-gtk2-dev.
      Closes: bug#674970. Thanks to Aaron M. Ucko.
    + Fix have python-sugar3 depend on imported GIR bindings.
    + Build-depend on dh-buildinfo: Works with multiarch now.
    + Relax libsugarext0 to recommend (not depend on) libsugarext-data.
  * Improve libsugarext-data long description to clarify it contains
    translations.

 -- Jonas Smedegaard <dr@jones.dk>  Tue, 29 May 2012 10:47:01 +0200

sugar-toolkit-gtk3 (0.96.1-1) unstable; urgency=low

  * Initial packaging release.
    Closes: bug#674802.

 -- Jonas Smedegaard <dr@jones.dk>  Mon, 28 May 2012 01:11:35 +0200