1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47
|
include /usr/share/dpkg/architecture.mk
BUILDDIR = $(CURDIR)/debian/build
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
dh $@ --builddirectory=$(BUILDDIR) --with python3
no_debug_info = mips64el mipsel
ifneq (,$(filter $(DEB_HOST_ARCH),$(no_debug_info)))
export DEB_CXXFLAGS_MAINT_APPEND += -g0
endif
ifneq ($(SALSABUILD),)
export DEB_CXXFLAGS_MAINT_APPEND += -g0
endif
DPKG_EXPORT_BUILDFLAGS = 1
export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
include /usr/share/dpkg/buildflags.mk
override_dh_auto_build-arch:
dh_auto_build -a
cd $(BUILDDIR) && $(MAKE) man
override_dh_auto_build-indep:
cd $(BUILDDIR) && $(MAKE) doxygen
override_dh_auto_install:
dh_auto_install
find . -type d -name "__pycache__" -exec rm -r {} +
find $(CURDIR)/debian/tmp/usr/share -type f -name "*.so" -exec rm -r {} +
override_dh_auto_test-arch:
mkdir $(CURDIR)/tests_auto
cd $(CURDIR)/tests_auto; cp $(CURDIR)/debian/tests/hokkaido/* ./; SUMO_HOME=$(CURDIR) ../bin/sumo -b 0 -e 10000 -n net.net.xml -r input_routes.rou.xml --summary-output sum.out
cat $(CURDIR)/tests_auto/sum.out
rm -rf $(CURDIR)/tests_auto
override_dh_auto_test-indep:
|