File: changelog

package info (click to toggle)
sup-mail 0.22.1-2
  • links: PTS, VCS
  • area: main
  • in suites: buster, stretch
  • size: 1,136 kB
  • ctags: 1,490
  • sloc: ruby: 12,583; sh: 115; makefile: 9
file content (232 lines) | stat: -rw-r--r-- 8,020 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
sup-mail (0.22.1-2) unstable; urgency=medium

  * Team upload.

  [ Cédric Boutillier ]
  * Remove version in the gem2deb build-dependency
  * Use https:// in Vcs-* fields
  * Run wrap-and-sort on packaging files

  [ Christian Hofstaedtler ]
  * Do not install xapian from source (Closes: #816486)
  * Bump Standards-Version to 3.9.8

 -- Christian Hofstaedtler <zeha@debian.org>  Thu, 07 Jul 2016 16:24:28 +0200

sup-mail (0.22.1-1) unstable; urgency=low

  * New upstream release. (Closes: #796054, #789605, #766168, #764315)
  * Added script for regenerating man pages from upstream.
  * Removed obsolete patch for commenting out rubygems imports.
  * Update man pages from wiki
    + sup-mail.1
    + sup-sync.1
  * Include Bash completions.
    + Add patch to use Debianized sup(-mail) command in completion.

 -- Per Andersson <avtobiff@debian.org>  Fri, 09 Oct 2015 00:14:35 +0200

sup-mail (0.20.0-1) unstable; urgency=low

  * New upstream release.
    - Use upstream man pages
  * d/compat: Set to 9, since we use debhelper 9.
  * Bump Standard-Version to 3.9.6, no changes needed
  * Add gpg data to d/source/include-binaries (user for testing).

 -- Per Andersson <avtobiff@debian.org>  Tue, 07 Oct 2014 11:47:58 +0200

sup-mail (0.19.0-1) unstable; urgency=medium

  [ Cédric Boutillier ]
  * debian/control: remove obsolete DM-Upload-Allowed flag
  * use canonical URI in Vcs-* fields

  [ Caitlin Matos ]
  * new upstream release (Closes: #739714)
    + Numerous bug fixes, Closes: #518723, #688817, #688851
  * d/control:
    - new homepage
    - added self to uploaders
    - updated ruby versions (previously depended on 1.9)
      (Closes: #744038, #747878)
    - removed BD ruby-eventmachine, ruby-yajl
    - new BDs ruby-rr, ruby-minitest, ruby-unicode
    - new dependency ruby-unicode
    - versioned dependencies as specified in gemspec 
      (modified for Debian versioning)
  * d/copyright:
    - new development team (Sup developers)
    - separate paragraph for new file test/test_crypto.rb
    - updated years
    - added self
  * d/patches: refreshed 0001, removed 0002-0006 (all obsolete)
  * d/watch updated
  * d/sup-mail.docs updated
  * d/NEWS updated

  [ Per Andersson ]
  * d/rules: Remove bin/sup-sync-back removal, not included upstream
  * Bump Standards-Version to 3.9.5, no changes needed
  * Add man pages for sup-psych-ify-config-files and sup-sync-back-maildir
  * Use my Debian address

 -- Per Andersson <avtobiff@debian.org>  Wed, 01 Oct 2014 20:59:52 +0200

sup-mail (0.12.1+git20120407.aaa852f-2) unstable; urgency=low

  * Updated text wrapping patch (0004) to work with Ruby 1.9.
    (Closes: #683781)

 -- Per Andersson <avtobiff@gmail.com>  Fri, 04 Aug 2012 00:15:00 +0200

sup-mail (0.12.1+git20120407.aaa852f-1) unstable; urgency=low

  * New maintainer. (Closes: #660509)
  * New upstream version.
    - Inline GPG support. (Closes: #526868)
  * Updated debian/copyright to DEP-5 copyright format.
  * Comply with gem2deb packaging.
    - Use dh --buildsystem=ruby --with ruby.
    - Add XS-Ruby-Versions to debian/control.
    - Run tests during build.
    - Patch tests so they all pass.
    - Add Build-Depends for running all tests.
    - Build for Ruby 1.9.1.
  * Bump standards version to 3.9.3, no changes needed.
  * Use source format 3.0 (quilt).
  * Remove IMAP-folder support from description. (Closes: #614301)
  * Depend on ruby-yajl and ruby-eventmachine, required for sup-cmd.
    (Closes: #627916, #627758)
  * Recommend ruby-gpgme. (Closes: #626297)
  * Add man pages for all binaries in /usr/bin. (Closes: #573871)
  * Include protocol.md in docs.
  * Not including sup-sync-back with package since it only fails with the
    message "does not work yet".
  * Add color scheme examples and mention ~/.sup/colors.yaml in sup-mail(1).
    (Closes: #556980)
  * Patch out all requires of rubygems.
  * Include contrib/colorpicker.rb and devel in examples.
  * Include zsh completion.
  * Add watch file.
  * Add patch for gpgme 2.0 support.
  * Add patch for avoiding crashes when (maybe) wrapping text, happens when
    expanding GPG signatures.
  * Remove deprecated dependency on libnet-ssh-ruby1.8, support for mbox+ssh
    sources is dropped.
  * Add unapply-patches to debian/source/local-options.
  * Change dependencies to packages following new Ruby policy
    - libhighline-ruby => ruby-highline
    - liblockfile-ruby => ruby-lockfile
    - libmime-types-ruby => ruby-mime-types
    - libncurses-ruby => ruby-ncurses
    - librmail-ruby1.8 => ruby-rubymail
    - libtrollop-ruby => ruby-trollop
    - libxapian-ruby1.8 => libxapian-ruby1.9.1 (Closes: #555515)
  * Depend on ruby-locale instead of libgettext-ruby1.9.1.
    - Add patch for requiring iconv and locale instead of gettext.
  * Add patch for using RbConfig instead of deprecated Config.
  * Provide virtual package mail-reader.

 -- Per Andersson <avtobiff@gmail.com>  Thu, 21 Jun 2012 20:29:15 +0200

sup-mail (0.12.1-1) unstable; urgency=low

  * New upstream version

 -- Decklin Foster <decklin@red-bean.com>  Thu, 10 Feb 2011 13:10:10 -0500

sup-mail (0.11-2) unstable; urgency=low

  * Remove stray rubygems requires (Closes: #579703)

 -- Decklin Foster <decklin@red-bean.com>  Sat, 01 May 2010 23:05:05 -0400

sup-mail (0.11-1) unstable; urgency=low

  * New upstream version

 -- Decklin Foster <decklin@red-bean.com>  Sun, 18 Apr 2010 18:31:56 -0400

sup-mail (0.10.2-1) unstable; urgency=low

  * New upstream version
    - Xapian is now the default backend, so it's been promoted to Depends.
      Ferret is still there in case you have not converted your index, but
      you should read NEWS.Debian for instructions on doing so.

 -- Decklin Foster <decklin@red-bean.com>  Wed, 27 Jan 2010 18:37:22 -0500

sup-mail (0.9.1-1) unstable; urgency=low

  * New upstream version
  * Recommend libxapian-ruby (backend works pretty well now)

 -- Decklin Foster <decklin@red-bean.com>  Wed, 06 Jan 2010 09:29:37 -0500

sup-mail (0.9-1) unstable; urgency=low

  * New upstream version

 -- Decklin Foster <decklin@red-bean.com>  Mon, 12 Oct 2009 16:47:08 -0400

sup-mail (0.8.1-1) unstable; urgency=low

  * New upstream version
    - Numeric labels work (Closes: #518758)

 -- Decklin Foster <decklin@red-bean.com>  Fri, 03 Jul 2009 18:13:47 -0400

sup-mail (0.7-1) unstable; urgency=low

  * New upstream version
    - Index locking fixed (Closes: #520070)

 -- Decklin Foster <decklin@red-bean.com>  Sat, 28 Mar 2009 15:27:50 -0400

sup-mail (0.6+20081111-1) unstable; urgency=low

  * Git snapshot release, from master (which has not changed much recently).
    Additional fixes of mine merged from next:
    - Read in X-Foo headers
    - Don't redirect run-mailcap to /dev/null
  * Correct manual page symlinks (Closes: #518482)
  * Fix invocation printed by sup-config (Closes: #518479)
  * Default to Debian sensible-editor, not vi

 -- Decklin Foster <decklin@red-bean.com>  Sat, 07 Mar 2009 18:16:36 -0500

sup-mail (0.6-3) unstable; urgency=low

  * Update CONTRIBUTORS from upstream git, and add Sam Roberts to
    debian/copyright (he is the main author of the included rfc2047.rb,
    a separate project).

 -- Decklin Foster <decklin@red-bean.com>  Sat, 01 Nov 2008 18:40:50 -0400

sup-mail (0.6-2) unstable; urgency=low

  * Correct command name in man page; distinguish "Sup" the client in
    general from "sup-mail" the binary. (Closes: #503142)

 -- Decklin Foster <decklin@red-bean.com>  Thu, 23 Oct 2008 12:47:18 -0400

sup-mail (0.6-1) unstable; urgency=low

  * New upstream version
  * Fix bin and man page names to reflect 'sup-mail' package name

 -- Decklin Foster <decklin@red-bean.com>  Mon, 29 Sep 2008 19:06:32 -0400

sup-mail (0.5-2) unstable; urgency=low

  * Merge upstream fix for respond_to? crash

 -- Decklin Foster <decklin@red-bean.com>  Thu, 26 Jun 2008 23:20:54 -0400

sup-mail (0.5-1) unstable; urgency=low

  * Initial release (Closes: #450602)

 -- Decklin Foster <decklin@red-bean.com>  Mon, 02 Jun 2008 13:34:24 -0400