1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89
|
From: =?utf-8?q?David_Pr=C3=A9vot?= <david@tilapin.org>
Date: Fri, 22 Sep 2017 03:55:27 -1000
Subject: Drop test failing outside Composer environment
.../weak_vendors_on_non_vendor.phpt | 74 ----------------------
1 file changed, 74 deletions(-)
delete mode 100644 src/Symfony/Bridge/PhpUnit/Tests/DeprecationErrorHandler/weak_vendors_on_non_vendor.phpt
diff --git a/src/Symfony/Bridge/PhpUnit/Tests/DeprecationErrorHandler/weak_vendors_on_non_vendor.phpt b/src/Symfony/Bridge/PhpUnit/Tests/DeprecationErrorHandler/weak_vendors_on_non_vendor.phpt
deleted file mode 100644
index 9c72a8e..0000000
@@ -1,74 +0,0 @@
-Test DeprecationErrorHandler in weak vendors mode on a non vendor file
-<?php
-
-$k = 'SYMFONY_DEPRECATIONS_HELPER';
-putenv($k.'='.$_SERVER[$k] = $_ENV[$k] = 'max[self]=0');
-putenv('ANSICON');
-putenv('ConEmuANSI');
-putenv('TERM');
-
-$vendor = __DIR__;
-while (!file_exists($vendor.'/vendor')) {
- $vendor = dirname($vendor);
-}
-define('PHPUNIT_COMPOSER_INSTALL', $vendor.'/vendor/autoload.php');
-require PHPUNIT_COMPOSER_INSTALL;
-require_once __DIR__.'/../../bootstrap.php';
-
-@trigger_error('root deprecation', E_USER_DEPRECATED);
-
-eval(<<<'EOPHP'
-namespace PHPUnit\Util;
-
-class Test
-{
- public static function getGroups()
- {
- return array();
- }
-}
-EOPHP
-);
-
-class FooTestCase
-{
- public function testLegacyFoo()
- {
- @trigger_error('silenced foo deprecation', E_USER_DEPRECATED);
- trigger_error('unsilenced foo deprecation', E_USER_DEPRECATED);
- trigger_error('unsilenced foo deprecation', E_USER_DEPRECATED);
- }
-
- public function testNonLegacyBar()
- {
- @trigger_error('silenced bar deprecation', E_USER_DEPRECATED);
- trigger_error('unsilenced bar deprecation', E_USER_DEPRECATED);
- }
-}
-
-$foo = new FooTestCase();
-$foo->testLegacyFoo();
-$foo->testNonLegacyBar();
-
-?>
-Unsilenced deprecation notices (3)
-
- 2x: unsilenced foo deprecation
- 2x in FooTestCase::testLegacyFoo
-
- 1x: unsilenced bar deprecation
- 1x in FooTestCase::testNonLegacyBar
-
-Legacy deprecation notices (1)
-
-Other deprecation notices (2)
-
- 1x: root deprecation
-
- 1x: silenced bar deprecation
- 1x in FooTestCase::testNonLegacyBar
-
-
|