1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32
|
export PYBUILD_DESTDIR_python3=debian/python3-sympy/
%:
dh $@ --with python3,sphinxdoc --buildsystem=pybuild
override_dh_auto_build:
dh_auto_build
faketime "`dpkg-parsechangelog -S date`" \
sh -c '(cd doc/; make html)'
override_dh_auto_install:
dh_auto_install
mv debian/python3-sympy/usr/bin/isympy debian/isympy-common/usr/bin/
mv debian/python3-sympy/usr/share/man/man1/* \
debian/isympy-common/usr/share/man/man1/
rm -rf debian/python*-sympy/usr/bin/
rm -rf debian/python*-sympy/usr/share/man/
rm -rf debian/python*-sympy/usr/lib/python*/dist-packages/sympy/mpmath/
override_dh_auto_clean:
dh_auto_clean
(cd doc/; make clean)
rm -rf sympy.egg-info
override_dh_auto_test:
|