1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
|
From: Louis-Philippe Véronneau <pollo@debian.org>
Date: Tue, 30 May 2023 17:11:41 -0400
Subject: Hardcode a PEP-440-compliant version
This hotfix patch fixes a problem with syncthing-gtk's current
Debian version not respecting PEP-440 and thus crashing other packages. By
bypassing the get_version() function altogether, the version used by the
package doesn't include the git hash.
This patch should probably be revisited after the release of Debian Bookworm
to find long-term solution.
Forwarded: not-needed
Bug-Debian: http://bugs.debian.org/1036947
setup.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
index ee2b457..90ba344 100755
@@ -119,7 +119,7 @@ if __name__ == "__main__":
]
setup(
name='syncthing-gtk',
- version=get_version(),
+ version='0.9.4.4.post20221205',
description='GTK3 GUI for Syncthing',
url='https://github.com/syncthing/syncthing-gtk',
packages=['syncthing_gtk'],
|