1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335
|
export LC_ALL = C.UTF-8
include /usr/share/dpkg/default.mk
include /usr/share/debhelper/dh_package_notes/package-notes.mk
ifeq (amd64,$(DEB_HOST_ARCH))
export TEMPLATE_EFI_ARCH=x64
else ifeq (arm64,$(DEB_HOST_ARCH))
export TEMPLATE_EFI_ARCH=aa64
endif
ifneq ("$(wildcard /.build/build.dist)","")
export DEB_BUILD_PROFILES += pkg.systemd.upstream
DH_ADDONS = --with=signobs
endif
ifeq ($(DEB_VENDOR),Ubuntu)
DEFAULT_NTP_SERVERS = ntp.ubuntu.com
SUPPORT_URL = http://www.ubuntu.com/support
CONFFLAGS_DISTRO = \
-Duser-path=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin \
-Ddefault-llmnr=no \
-Ddefault-mdns=no
else
DEFAULT_NTP_SERVERS = 0.debian.pool.ntp.org 1.debian.pool.ntp.org 2.debian.pool.ntp.org 3.debian.pool.ntp.org
SUPPORT_URL = https://www.debian.org/support
CONFFLAGS_DISTRO =
endif
TEST_TIMEOUT_MULTIPLIER = "-t 10"
ifeq (, $(filter pkg.systemd.upstream, $(DEB_BUILD_PROFILES)))
DH_MISSING ?= --fail-missing
GENSYMBOLS_LEVEL ?= 4
VERSION_TAG = $(DEB_VERSION)
else
DH_MISSING ?= --list-missing
GENSYMBOLS_LEVEL ?= 1
VERSION_TAG = $(DEB_VERSION_UPSTREAM)
endif
export DEB_BUILD_MAINT_OPTIONS = optimize=+lto hardening=+pie $(DEB_BUILD_OPTIONS)
CONFFLAGS = \
-Dstatic-libsystemd=true \
-Dversion-tag="$(VERSION_TAG)" \
-Dquotaon-path=/usr/sbin/quotaon \
-Dquotacheck-path=/usr/sbin/quotacheck \
-Dkmod-path=/usr/bin/kmod \
-Dkexec-path=/usr/sbin/kexec \
-Dsulogin-path=/usr/sbin/sulogin \
-Dmount-path=/usr/bin/mount \
-Dumount-path=/usr/bin/umount \
-Dloadkeys-path=/usr/bin/loadkeys \
-Dsetfont-path=/usr/bin/setfont \
-Dnologin-path=/usr/sbin/nologin \
-Dsysvinit-path=/etc/init.d \
-Dsysvrcnd-path=/etc \
-Dlocalegen-path=/usr/sbin/locale-gen \
-Ddebug-shell=/usr/bin/bash \
-Dzshcompletiondir=/usr/share/zsh/vendor-completions \
-Ddbuspolicydir=/usr/share/dbus-1/system.d/ \
-Dsupport-url=$(SUPPORT_URL) \
-Ddefault-kill-user-processes=false \
-Ddefault-dnssec=no \
-Dpamconfdir=no \
-Dpamlibdir=/usr/lib/$(DEB_HOST_MULTIARCH)/security \
-Drpmmacrosdir=no \
-Dvconsole=false \
-Dfirstboot=true \
-Dxkbcommon=disabled \
-Dwheel-group=false \
-Doomd=true \
-Durlify=true \
-Dgnutls=disabled \
-Dntp-servers="$(DEFAULT_NTP_SERVERS)" \
-Dsystem-uid-max=999 \
-Dsystem-gid-max=999 \
-Dnobody-user=nobody \
-Dnobody-group=nogroup \
-Ddev-kvm-mode=0660 \
-Dgroup-render-mode=0660 \
-Drepart=enabled \
-Dfdisk=enabled \
-Dsysext=true \
-Dselinux=enabled \
-Dhwdb=true \
-Dsysusers=true \
-Dinstall-tests=$(if $(filter noinsttest,$(DEB_BUILD_PROFILES)),false,true) \
-Dman=$(if $(filter nodoc,$(DEB_BUILD_PROFILES)),disabled,enabled) \
-Ddbus-interfaces-dir=$(if $(filter nodoc,$(DEB_BUILD_PROFILES)),no,yes) \
-Dtranslations=true \
-Dnss-myhostname=true \
-Dnss-mymachines=enabled \
-Dnss-resolve=enabled \
-Dnss-systemd=true \
-Dresolve=true \
-Dstatus-unit-format-default=combined \
-Dstandalone-binaries=true \
-Dutmp=false \
-Dtty-mode=0600 \
-Dmode=$(if $(filter pkg.systemd.upstream,$(DEB_BUILD_PROFILES)),developer,release)
ifeq ($(filter nocheck,$(DEB_BUILD_PROFILES))$(filter noinsttest,$(DEB_BUILD_PROFILES)),nochecknoinsttest)
CONFFLAGS += -Dtests=false
else
CONFFLAGS += -Dtests=true
endif
ifeq (, $(filter stage1, $(DEB_BUILD_PROFILES)))
CONFFLAGS += \
-Daudit=enabled \
-Dlibcryptsetup=enabled \
-Dlibcryptsetup-plugins=enabled \
-Dcoredump=true \
-Delfutils=enabled \
-Dapparmor=enabled \
-Dlibidn2=enabled \
-Dlibiptc=enabled \
-Dlibcurl=enabled \
-Dimportd=enabled \
-Dmicrohttpd=enabled \
-Dopenssl=enabled \
-Dcryptolib=openssl \
-Ddns-over-tls=openssl \
-Dlibfido2=enabled \
-Dtpm2=enabled \
-Dp11kit=enabled \
-Dqrencode=enabled \
-Dpwquality=enabled \
-Dhomed=enabled \
-Duserdb=true \
-Dpcre2=enabled \
-Dukify=enabled \
-Dbootloader=$(if $(filter amd64 i386 arm64 armhf loong64 riscv64,$(DEB_HOST_ARCH)),enabled,disabled) \
-Dsysupdate=enabled
else
CONFFLAGS += \
-Daudit=disabled \
-Dlibcryptsetup=disabled \
-Dlibcryptsetup-plugins=disabled \
-Dcoredump=false \
-Delfutils=disabled \
-Dapparmor=disabled \
-Dlibidn2=disabled \
-Dlibiptc=disabled \
-Dlibcurl=disabled \
-Dimportd=disabled \
-Dmicrohttpd=disabled \
-Dopenssl=disabled \
-Dlibfido2=disabled \
-Dtpm2=disabled \
-Dp11kit=disabled \
-Dqrencode=disabled \
-Dpwquality=disabled \
-Dhomed=disabled \
-Duserdb=false \
-Dpcre2=disabled \
-Dukify=disabled \
-Dbootloader=disabled \
-Dsysupdate=disabled
endif
ifeq (, $(filter $(DEB_BUILD_PROFILES), stage1 pkg.systemd.nobpf))
ifneq (,$(filter $(DEB_TARGET_ARCH), amd64 arm64 ppc64el riscv64 s390x))
CONFFLAGS += \
-Dvmlinux-h=provided \
-Dbpf-framework=enabled \
-Dbpf-compiler=clang
ifneq ($(DEB_VENDOR),Ubuntu)
CONFFLAGS += -Dvmlinux-h-path=/usr/include/$(DEB_HOST_MULTIARCH)/linux/bpf/vmlinux.h
else
CONFFLAGS += -Dvmlinux-h-path=/usr/include/$(DEB_HOST_MULTIARCH)/linux/vmlinux.h
bpftool_binary := $(shell find /usr/lib/linux-tools/ /usr/lib/linux-tools-* -name 'bpftool' -perm /u=x 2>/dev/null | sort -r | head -n1)
ifneq ($(bpftool_binary),)
export PATH := $(shell dirname $(bpftool_binary)):$(PATH)
endif
endif
endif
endif
ifeq (, $(filter pkg.systemd.upstream, $(DEB_BUILD_PROFILES)))
CONFFLAGS += -Ddns-servers=''
CONFFLAGS += -Dsbat-distro-url=https://tracker.debian.org/pkg/systemd
else
CONFFLAGS += -Dsbat-distro-url=https://github.com/systemd/systemd
CONFFLAGS += -Dsbat-distro=upstream
CONFFLAGS += -Dsbat-distro-summary='Upstream build from git'
endif
ifneq (,$(filter $(DEB_TARGET_ARCH), arm64 armhf riscv64))
CONFFLAGS += -Defi-stub-extra-sections=500
endif
override_dh_auto_configure:
dh_auto_configure \
-- $(CONFFLAGS) $(CONFFLAGS_DISTRO) $(CONFFLAGS_UPSTREAM)
execute_before_dh_auto_build:
@echo 'blhc: ignore-line-regexp: .* -o test-bus-vtable-cc.*'
@echo 'blhc: ignore-line-regexp: .*cc -E.*'
@echo 'blhc: ignore-line-regexp: .* -o src/boot/.*'
@echo 'blhc: ignore-line-regexp: .* Compiling C object fuzz.*'
execute_before_dh_auto_clean:
ifneq (, $(filter pkg.systemd.upstream, $(DEB_BUILD_PROFILES)))
debian/extra/checkout-upstream
endif
execute_before_dh_install:
rm -rf debian/tmp/usr/share/doc/systemd/LICENSES/
rm -f debian/tmp/usr/share/doc/systemd/LICENSE.*
rm -f debian/tmp/usr/lib/udev/*.d/README
if [ -d debian/tmp/usr/lib/sysusers.d/ ]; then \
debian/extra/make-sysusers-basic > debian/tmp/usr/lib/sysusers.d/basic.conf; \
fi
execute_after_dh_install-arch:
ifeq ($(DEB_VENDOR),Ubuntu)
install -D --mode=644 debian/extra/udev.py debian/udev/usr/share/apport/package-hooks/udev.py
install -D --mode=644 debian/extra/systemd.py debian/systemd/usr/share/apport/package-hooks/systemd.py
install --mode=644 debian/extra/rules-ubuntu/*.rules debian/udev/usr/lib/udev/rules.d/
install -D --mode=644 debian/extra/resolved.conf.d/cache-no-negative.conf debian/systemd-resolved/usr/lib/systemd/resolved.conf.d/cache-no-negative.conf
cp -a debian/extra/units-ubuntu/* debian/systemd/usr/lib/systemd/system/
endif
ifeq (,$(filter stage1, $(DEB_BUILD_PROFILES)))
ifeq ($(DEB_VENDOR),Debian)
ifneq ($(TEMPLATE_EFI_ARCH),)
debian/extra/gen-signing-template $(DEB_VERSION) $(DEB_HOST_ARCH) $(TEMPLATE_EFI_ARCH)
endif
endif
endif
override_dh_missing:
dh_missing $(DH_MISSING)
override_dh_installsystemd:
dh_installsystemd -psystemd-timesyncd
dh_installsystemd -psystemd-oomd systemd-oomd.service
dh_installsystemd -psystemd-oomd --no-stop-on-upgrade systemd-oomd.socket
dh_installsystemd -psystemd-container --no-stop-on-upgrade machines.target
dh_installsystemd -psystemd-userdbd --no-stop-on-upgrade systemd-userdbd.socket
dh_installsystemd -psystemd-homed --no-also systemd-homed.service systemd-homed-activate.service
dh_installsystemd -psystemd-resolved
dh_installsystemd -pudev systemd-udevd.service
override_dh_installsystemduser:
execute_after_dh_installsysusers:
dh_installsysusers -pudev --name=debian-udev
PROJECT_VERSION ?= $(shell awk '/(PROJECT|PACKAGE)_VERSION / {print $$3}' obj-$(DEB_HOST_GNU_TYPE)/config.h | tr -d \")
# The SysV compat tools (which are symlinks to systemctl) are
# quasi-essential, so add their dependencies to Pre-Depends
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=753589
override_dh_shlibdeps:
dh_shlibdeps -psystemd -Llibsystemd-shared -- \
-dPre-Depends -edebian/systemd/usr/bin/systemctl \
-dDepends
dh_shlibdeps -plibsystemd-shared -lusr/lib/$(DEB_HOST_MULTIARCH)/systemd
dh_shlibdeps --remaining-packages -Llibsystemd-shared
override_dh_makeshlibs:
sed 's/SHARED_LIB_VERSION/$(PROJECT_VERSION)/' debian/shlibs.local.in > debian/shlibs.local
dh_makeshlibs -plibsystemd-shared -Xlibsystemd-shared -Xlibsystemd-core -- -c$(GENSYMBOLS_LEVEL)
dh_makeshlibs --remaining-packages -- -c$(GENSYMBOLS_LEVEL)
# Ensure builds against the udeb package gets a dependency on libudev1-udeb. The last time a symbol
# was added was in 247, and the API is pretty much frozen, so we can have a fixed version here.
echo 'udeb: libudev 1 libudev1-udeb (>= 247)' >> debian/libudev1/DEBIAN/shlibs
override_dh_auto_test:
ifeq (, $(filter nocheck, $(DEB_BUILD_OPTIONS)))
# some tests hang under fakeroot, so disable fakeroot
env -u LD_PRELOAD meson test -C obj-$(DEB_HOST_GNU_TYPE) --print-errorlogs $(TEST_TIMEOUT_MULTIPLIER)
endif
ifeq ($(DEB_VENDOR),Ubuntu)
ifeq (, $(filter pkg.systemd.upstream, $(DEB_BUILD_PROFILES)))
execute_after_dh_link:
# Mask systemd-gpt-auto-generator by default on Ubuntu
dh_link -psystemd /dev/null /etc/systemd/system-generators/systemd-gpt-auto-generator
endif
endif
%:
dh $@ $(DH_ADDONS)
# TODO: ideally it should be possible to disable this via an env var or DEB_BUILD_OPTIONS
override_dh_strip_nondeterminism:
ifeq (, $(filter pkg.systemd.upstream, $(DEB_BUILD_PROFILES)))
dh_strip_nondeterminism
endif
|