File: prerm

package info (click to toggle)
tetrinetx 1.13.16-14
  • links: PTS
  • area: main
  • in suites: bullseye, buster, jessie, jessie-kfreebsd, sid, stretch, wheezy
  • size: 512 kB
  • ctags: 500
  • sloc: ansic: 6,955; sh: 110; makefile: 58
file content (19 lines) | stat: -rw-r--r-- 429 bytes parent folder | download | duplicates (5)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
#!/bin/sh
set -e

ACTION=$1 ; shift

case "$ACTION" in
  failed-upgrade)
    VERSION=$1 ; shift
    DEBVER=`echo $VERSION | cut -d- -f2`
    if [ "$DEBVER" -lt "5" ]; then
      # dont try to stop -> do nothing and return success.
      echo -n "Version prior to 5 are not daemonized correctly: "
      echo    "Not running tetrinetx init script."
      exit 0
    fi
    # else let the debhelper stuff acting.
esac

#DEBHELPER#