1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84
|
export DH_OPTIONS
DEB_CFLAGS_MAINT_APPEND=-Wall
DEB_CFLAGS_MAINT_STRIP=-Werror=format-security
include /usr/share/dpkg/architecture.mk
include /usr/share/dpkg/buildflags.mk
export CPPFLAGS CFLAGS LDFLAGS
export PERL_EXT_CFLAGS := $(CFLAGS)
export PERL_EXT_CPPFLAGS := $(CPPFLAGS)
export PERL_EXT_LDFLAGS := $(LDFLAGS)
texinfo := $(CURDIR)/debian/texinfo
ii := $(CURDIR)/debian/install-info
infopkg := $(CURDIR)/debian/info
tmpdir := $(CURDIR)/debian/tmp
%:
dh $@
override_dh_auto_configure:
AWK=awk ./configure \
--with-external-Text-Unidecode=yes \
--prefix=/usr \
--libexecdir='$${prefix}/lib' \
--infodir='$${prefix}/share/info' --mandir='$${prefix}/share/man' \
--build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
execute_before_dh_auto_build:
cp man/texi2dvi.1 debian
execute_after_dh_auto_build:
cd doc && env TEXINFO_DEV_SOURCE=1 ../tp/texi2any --html info-stnd
cd doc && env TEXINFO_DEV_SOURCE=1 ../tp/texi2any --html texinfo
mv debian/texi2dvi.1 man/
touch man/texi2dvi.1
override_dh_auto_install:
$(MAKE) install install-tex prefix=$(tmpdir)/usr \
TEXMF=$(tmpdir)/usr/share/texmf
override_dh_install:
find $(tmpdir) -type f -name dir | xargs rm -f
desktop-file-install --dir=$(tmpdir)/usr/share/applications debian/info.desktop
sed -i "/dependency_libs/ s/'.*'/''/" `find $(tmpdir) -name '*.la'`
rm -rf $(tmpdir)/usr/share/texmf/tex/generic
dh_install
dh_missing --fail-missing --sourcedir=debian/tmp -X share/info
override_dh_auto_test:
override_dh_installchangelogs:
dh_installchangelogs ChangeLog
override_dh_perl:
dh_perl /usr/lib/texinfo
update-texinfo.tex:
wget -O $(CURDIR)/debian/texinfo.tex ftp://tug.org/tex/texinfo.tex
|