File: changelog

package info (click to toggle)
thin 1.7.2-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 444 kB
  • sloc: ruby: 1,832; ansic: 1,738; sh: 82; makefile: 10
file content (130 lines) | stat: -rw-r--r-- 3,982 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
thin (1.7.2-1) unstable; urgency=medium

  * Team upload

  [ Cédric Boutillier ]
  * Remove version in the gem2deb build-dependency

  [ Antonio Terceiro ]
  * New upstream version 1.7.2
  * Update packaging with new run of `dh-make-ruby`

 -- Antonio Terceiro <terceiro@debian.org>  Fri, 11 Jan 2019 14:57:43 -0300

thin (1.6.3-2) unstable; urgency=medium

  * Team upload.
  * Drop transitional package thin1.8

 -- Antonio Terceiro <terceiro@debian.org>  Mon, 09 Mar 2015 14:15:18 -0300

thin (1.6.3-1) experimental; urgency=medium

  * Team upload.
  * New upstream release.
  * Patches:
    - dont-allow-install: refreshed
    - fix_require_path_for_thin_parser.patch: removed, fixed upstream
    - fix_hardening_FTBFS.patch: removed, fixed upstream

 -- Antonio Terceiro <terceiro@debian.org>  Mon, 09 Mar 2015 14:12:06 -0300

thin (1.3.1-5) unstable; urgency=medium

  * Team upload.
  * Use standard search path for thin_parser (Closes: #737032)

 -- Christian Hofstaedtler <zeha@debian.org>  Wed, 26 Feb 2014 00:22:32 +0100

thin (1.3.1-4) unstable; urgency=low

  Team upload.

  [ Cédric Boutillier ]
  * use canonical URI in Vcs-* fields

  [ Christian Hofstaedtler ]
  * Add alternative dependency on ruby-rack1.4
  * Update Standards-Version to 3.9.5 (no changes)

 -- Christian Hofstaedtler <zeha@debian.org>  Mon, 02 Dec 2013 20:46:56 +0100

thin (1.3.1-3) unstable; urgency=low

  * Team upload.
  * Bump build dependency on gem2deb to >= 0.3.0~.

 -- Paul van Tilburg <paulvt@debian.org>  Wed, 27 Jun 2012 20:54:08 +0200

thin (1.3.1-2) unstable; urgency=low

  * Add patch to pass format string as %s to allow for compiling with
    hardnening options (Closes: #676211)
  * Fix debian/gen_init.rb to use FileUtils for supporting Ruby 1.9
  * Fix with machine readable copyright format 1.0
  * Add set -e to maintainer scripts
  * Update Standards-Version to 3.9.3

 -- Ryan Niebur <ryan@debian.org>  Sat, 16 Jun 2012 12:56:33 -0700

thin (1.3.1-1.1) unstable; urgency=high

  * Non-maintainer upload.
  * Urgency high because package is uninstallable
  * Fix missing shebang in maintainer scripts

 -- Ondřej Surý <ondrej@debian.org>  Sat, 11 Feb 2012 12:17:04 +0100

thin (1.3.1-1) unstable; urgency=low

  [ Laurent Arnoud ]
  * New upstream release
  * Switch to gem2deb-based packaging. Binary package renamed to
      thin. Transitional packagesadded. (Closes: #652090)

  [ Ryan Niebur ]
  * change Priority of transitional packages to extra
  * update my e-mail address
  * install copies of thin script for each supported interpreter
  * Updated to newer upstream release (Closes: #653332)
  * convert to include only one thin script, which can ran under
    different interpreters using the -S flag: ruby1.9.1 -S thin start
    - document in README.Debian
  * switch back to using help2man to generate manpage

 -- Ryan Niebur <ryan@debian.org>  Sat, 28 Jan 2012 00:54:12 -0800

thin (1.2.4-1.1) unstable; urgency=high

  * Non-maintainer upload.
  * urgency=high because of an RC tiny bugfix.
  * Backport a patch from v1.2.6 in Rails adapter to properly detect Rack.
    Among other things, this fixes the ActiveRecord session store (when
    configured) on Rails. (Closes: #610288)

 -- Faidon Liambotis <paravoid@debian.org>  Tue, 18 Jan 2011 14:31:07 +0200

thin (1.2.4-1) unstable; urgency=low

  * New upstream release
  * set Standards-Version to 3.8.3
  * tarball from 1.2.3, patch up to 1.2.4

 -- Ryan Niebur <ryanryan52@gmail.com>  Mon, 07 Sep 2009 01:46:46 -0700

thin (1.2.2-1) unstable; urgency=low

  * New upstream version
    - update dependencies
    - refresh patches
  * add DM-Upload-Allowed field, so that I can upload this package
    myself in the future
  * add (build-)depends on libopenssl-ruby1.8

 -- Ryan Niebur <ryanryan52@gmail.com>  Thu, 21 May 2009 21:16:17 -0700

thin (1.2.0-1) unstable; urgency=low

  * Initial release (Closes: #504966)

 -- Ryan Niebur <ryanryan52@gmail.com>  Sat, 25 Apr 2009 12:40:38 -0700