1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93
|
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
CFLAGS += -Wall -g -I/usr/include/ncursesw
CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
config.status: configure
dh_testdir
./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
--prefix=/usr --mandir=\$${prefix}/share/man --sysconfdir=/etc \
CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
build: build-arch build-indep
build-arch: build-stamp
build-indep: build-stamp
build-stamp: config.status
dh_testdir
$(MAKE) all doc
touch build-stamp
clean:
dh_testdir
dh_testroot
rm -f build-stamp
$(MAKE) clean
rm -f config.h config.log config.make config.status
rm -rf doc/manual.html-chunked/
rm -f doc/manual.pdf doc/manual.html doc/manual.toc doc/manual.tex
rm -f doc/tigmanual.7
rm -f doc/tig.1 doc/tig.1.html doc/tigrc.5 doc/tigrc.5.html
rm -f INSTALL.html NEWS.html README.html
dh_clean
install: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
$(MAKE) install install-doc DESTDIR=$(CURDIR)/debian/tig
rm -f debian/tig/usr/share/doc/tig/INSTALL.html \
debian/tig/usr/share/doc/tig/README.html
mkdir -p debian/tig/usr/share/bash-completion/completions
cp contrib/tig-completion.bash debian/tig/usr/share/bash-completion/completions/tig
chmod 644 debian/tig/usr/share/bash-completion/completions/tig
binary-indep:
binary-arch: build install
dh_testdir
dh_testroot
dh_installchangelogs NEWS.adoc
dh_installdocs doc/manual.pdf
dh_installexamples contrib/*.tigrc
dh_link
dh_strip
dh_compress -X.pdf
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install
|