1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175
|
Description: Use a sorted map in TemplateSuite to make the output reproducible
Author: Emmanuel Bourg <ebourg@apache.org>
Forwarded: no
@@ -21,7 +21,7 @@
package org.apache.tiles.autotag.model;
import java.util.Collection;
-import java.util.LinkedHashMap;
+import java.util.TreeMap;
import java.util.Map;
/**
@@ -67,7 +67,7 @@
Iterable<? extends TemplateClass> classes) {
this.name = name;
this.documentation = documentation;
- templateClasses = new LinkedHashMap<String, TemplateClass>();
+ templateClasses = new TreeMap<String, TemplateClass>();
if (classes != null) {
for (TemplateClass templateClass : classes) {
templateClasses.put(templateClass.getName(), templateClass);
@@ -16,12 +16,12 @@
<tag>
<description>
<![CDATA[
- Documentation of the DoStuff class
+ Documentation of the DoStuffNoBody class
]]>
</description>
- <name>doStuff</name>
- <tag-class>org.apache.tiles.autotag.jsp.test.DoStuffTag</tag-class>
- <body-content>scriptless</body-content>
+ <name>doStuffNoBody</name>
+ <tag-class>org.apache.tiles.autotag.jsp.test.DoStuffNoBodyTag</tag-class>
+ <body-content>empty</body-content>
<attribute>
<description>
<![CDATA[
@@ -31,7 +31,7 @@
<name>one</name>
<required>true</required>
<rtexprvalue>true</rtexprvalue>
- <type>java.lang.String</type>
+ <type>java.lang.Double</type>
</attribute>
<attribute>
<description>
@@ -42,7 +42,7 @@
<name>two</name>
<required>false</required>
<rtexprvalue>true</rtexprvalue>
- <type>int</type>
+ <type>float</type>
</attribute>
<attribute>
<description>
@@ -53,18 +53,18 @@
<name>three</name>
<required>false</required>
<rtexprvalue>true</rtexprvalue>
- <type>long</type>
+ <type>java.util.Date</type>
</attribute>
</tag>
<tag>
<description>
<![CDATA[
- Documentation of the DoStuffNoBody class
+ Documentation of the DoStuff class
]]>
</description>
- <name>doStuffNoBody</name>
- <tag-class>org.apache.tiles.autotag.jsp.test.DoStuffNoBodyTag</tag-class>
- <body-content>empty</body-content>
+ <name>doStuff</name>
+ <tag-class>org.apache.tiles.autotag.jsp.test.DoStuffTag</tag-class>
+ <body-content>scriptless</body-content>
<attribute>
<description>
<![CDATA[
@@ -74,7 +74,7 @@
<name>one</name>
<required>true</required>
<rtexprvalue>true</rtexprvalue>
- <type>java.lang.Double</type>
+ <type>java.lang.String</type>
</attribute>
<attribute>
<description>
@@ -85,7 +85,7 @@
<name>two</name>
<required>false</required>
<rtexprvalue>true</rtexprvalue>
- <type>float</type>
+ <type>int</type>
</attribute>
<attribute>
<description>
@@ -96,7 +96,7 @@
<name>three</name>
<required>false</required>
<rtexprvalue>true</rtexprvalue>
- <type>java.util.Date</type>
+ <type>long</type>
</attribute>
</tag>
</taglib>
@@ -9,38 +9,38 @@
public class TldtestFMModelRepository {
/**
- * The "doStuff" directive.
+ * The "doStuffNoBody" directive.
*/
- private DoStuffFMModel doStuff;
+ private DoStuffNoBodyFMModel doStuffNoBody;
/**
- * The "doStuffNoBody" directive.
+ * The "doStuff" directive.
*/
- private DoStuffNoBodyFMModel doStuffNoBody;
+ private DoStuffFMModel doStuff;
/**
* Constructor.
*/
public TilesFMModelRepository() {
- doStuff = new DoStuffFMModel(new org.apache.tiles.autotag.template.DoStuffTemplate());
doStuffNoBody = new DoStuffNoBodyFMModel(new org.apache.tiles.autotag.template.DoStuffNoBodyTemplate());
+ doStuff = new DoStuffFMModel(new org.apache.tiles.autotag.template.DoStuffTemplate());
}
/**
- * Returns the "doStuff" directive.
+ * Returns the "doStuffNoBody" directive.
*
- * @return The "doStuff" directive.
+ * @return The "doStuffNoBody" directive.
*/
- public DoStuffFMModel getDoStuff() {
- return doStuff;
+ public DoStuffNoBodyFMModel getDoStuffNoBody() {
+ return doStuffNoBody;
}
/**
- * Returns the "doStuffNoBody" directive.
+ * Returns the "doStuff" directive.
*
- * @return The "doStuffNoBody" directive.
+ * @return The "doStuff" directive.
*/
- public DoStuffNoBodyFMModel getDoStuffNoBody() {
- return doStuffNoBody;
+ public DoStuffFMModel getDoStuff() {
+ return doStuff;
}
}
@@ -1,3 +1,3 @@
# This file was automatically generated by Apache Tiles Autotag.
-userdirective=org.apache.tiles.autotag.velocity.test.DoStuffDirective,\
- org.apache.tiles.autotag.velocity.test.DoStuffNoBodyDirective
\ No newline at end of file
+userdirective=org.apache.tiles.autotag.velocity.test.DoStuffNoBodyDirective,\
+ org.apache.tiles.autotag.velocity.test.DoStuffDirective
\ No newline at end of file
|