1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
|
DEB_BUILD_MAINT_OPTIONS= hardening=+all
export DEB_BUILD_MAINT_OPTIONS
DEB_CFLAGS_MAINT_APPEND= -Wall -W -ansi -pedantic -Wbad-function-cast \
-Wcast-align -Wcast-qual -Wchar-subscripts -Winline \
-Wmissing-prototypes -Wnested-externs -Wpointer-arith \
-Wredundant-decls -Wshadow -Wwrite-strings
ifneq (,$(filter werror,$(DEB_BUILD_OPTIONS)))
DEB_CFLAGS_MAINT_APPEND+= -Werror
endif
export DEB_CFLAGS_MAINT_APPEND
override_dh_installchangelogs:
dh_installchangelogs NEWS
%:
dh $@
|