1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66
|
configure: configure-stamp
configure-stamp:
dh_testdir
touch configure-stamp
build: build-arch build-indep
build-arch: build-stamp
build-indep: build-stamp
build-stamp:
build-stamp: configure-stamp
dh_testdir
touch build-stamp
clean:
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
dh_clean
install: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
binary-indep: build install
dh_testdir
dh_testroot
dh_installchangelogs
dh_installdocs -X README
dh_installexamples sample.csv
dh_install
chmod -x debian/tk2/usr/share/tk2/api2.tcl \
debian/tk2/usr/share/tk2/gui2.tcl debian/tk2/usr/share/tk2/misclib.tcl \
debian/tk2/usr/share/tk2/mylib.tcl
dh_installmenu
dh_installman tk2.1
dh_link
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_gencontrol
dh_md5sums
dh_builddeb
binary-arch: build install
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure
|