1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94
|
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
ifneq ($(DEB_HOST_GNU_TYPE),$(DEB_BUILD_GNU_TYPE))
CROSS= --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
else
CROSS= --build $(DEB_BUILD_GNU_TYPE)
endif
config: config-stamp
config-stamp:
dh_testdir
$(MAKE) -f /usr/share/quilt/quilt.make patch
autoreconf --force
ifneq "$(wildcard /usr/share/misc/config.sub)" ""
cp -f /usr/share/misc/config.sub config.sub
endif
ifneq "$(wildcard /usr/share/misc/config.guess)" ""
cp -f /usr/share/misc/config.guess config.guess
endif
./configure $(CROSS) \
--prefix=/usr \
--mandir=\$${prefix}/share/man \
--infodir=\$${prefix}/share/info \
--with-tcl=/usr/lib/tcl8.5/ \
--with-tk=/usr/lib/tk8.5/ \
--with-tclinclude=/usr/include/tcl8.5/ \
--with-tkinclude=/usr/include/tcl8.5/ \
CFLAGS="$(CFLAGS)" \
LDFLAGS="-lm -Wl,-z,defs -Wl,--no-undefined -Wl,--as-needed"
touch $@
build: build-stamp
build-stamp: config
dh_testdir
$(MAKE)
cp doc/treectrl.n treectrl.3tk
touch $@
clean:
dh_testdir
dh_testroot
rm -f build-stamp config-stamp
[ ! -f Makefile ] || $(MAKE) distclean
rm -f config.sub config.guess config.cache config.log
rm -f configure shellicon/configure
rm -f treectrl.3tk
$(MAKE) -f /usr/share/quilt/quilt.make unpatch
dh_clean
install: build
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
$(MAKE) install \
prefix=$(CURDIR)/debian/tktreectrl/usr \
DESTDIR=$(CURDIR)/debian/tktreectrl \
DIST_DIR=$(CURDIR)/debian/tktreectrl
find $(CURDIR)/debian/tktreectrl -empty -type d -delete
find $(CURDIR)/debian/tktreectrl -name "*.htm*" | while read f; do chmod -x "$$f"; done
binary-indep: build install
binary-arch: build install
dh_testdir
dh_testroot
dh_installchangelogs ChangeLog
dh_installdocs
dh_installexamples
dh_install
dh_installman
dh_link
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: config build clean binary-indep binary-arch binary install
|