File: changelog

package info (click to toggle)
tnftp 20130505-3
  • links: PTS
  • area: main
  • in suites: bullseye, buster, jessie, jessie-kfreebsd, sid, stretch
  • size: 2,868 kB
  • ctags: 2,374
  • sloc: ansic: 26,266; sh: 11,139; makefile: 207
file content (222 lines) | stat: -rw-r--r-- 6,689 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
tnftp (20130505-3) unstable; urgency=medium

  * Revert DH compatibility level to 7.
  * Set hardening options.

 -- Anibal Monsalve Salazar <anibal@debian.org>  Mon, 17 Nov 2014 06:51:16 +0000

tnftp (20130505-2) unstable; urgency=medium

  * Only trust filenames with special meaning if they came from
    the command line. CVE-2014-8517.
    Add upstream patch CVE-2014-8517.patch.
    Closes: #767171.
  * Run dh-autoreconf to update for new architectures.
    Patch by Brahadambal Srinivasan <latha@linux.vnet.ibm.com>.
    Closes: 759467.
  * Standards Version is 3.9.6.
  * Fix uses-deprecated-compression-for-data-tarball.
  * Fix build-depends-on-obsolete-package.
    build-depends: hardening-wrapper => use dpkg-buildflags instead.

 -- Anibal Monsalve Salazar <anibal@debian.org>  Thu, 06 Nov 2014 10:42:01 +0000

tnftp (20130505-1) unstable; urgency=low

  * New upstream version 20130505
  * Merged upstream: 02-518858-define-ARG_MAX.patch
  * Standards Version is 3.9.4
  * debian/control: Build-Depends on libssl-dev
  * Add debian/tnftp.lintian-overrides as the part of tnftp linked with
    OpenSSL is not covered by the GNU GPL
  * Update debian/rules

 -- Anibal Monsalve Salazar <anibal@debian.org>  Sun, 26 May 2013 10:01:38 +1000

tnftp (20100108-3) unstable; urgency=low

  * Standards Version is 3.9.3
  * Fix dh_installmanpages-is-obsolete
    Fix FTBFS
    Patch by Prach Pongpanich
    Closes: 663563

 -- Anibal Monsalve Salazar <anibal@debian.org>  Tue, 20 Mar 2012 18:44:30 +1100

tnftp (20100108-2) unstable; urgency=low

  * Source format is 3.0 (quilt)
  * Update homepage control line
  * Update debian/copyright and debian/watch 
  * Fix out-of-date-standards-version
  * Fix description-synopsis-starts-with-article
  * Fix debian-rules-missing-recommended-target

 -- Anibal Monsalve Salazar <anibal@debian.org>  Wed, 29 Jun 2011 11:30:21 +1000

tnftp (20100108-1) unstable; urgency=low

  * New upstream version 

 -- Anibal Monsalve Salazar <anibal@debian.org>  Wed, 27 Jan 2010 15:48:54 +1100

tnftp (20091122-1) unstable; urgency=low

  * New upstream version
  * Remove 03-552875-getline.patch (merged)
  * Build depend on libbsd-dev

 -- Anibal Monsalve Salazar <anibal@debian.org>  Fri, 15 Jan 2010 14:32:59 +1100

tnftp (20090606-2) unstable; urgency=low

  * Fix conflicting types for 'getline'
    Closes: 552875
  * Fix debhelper-but-no-misc-depends
  * Fix out-of-date-standards-version
  * Fix patch-system-but-no-source-readme
  * Fix maintainer-script-without-set-e

 -- Anibal Monsalve Salazar <anibal@debian.org>  Sat, 19 Dec 2009 12:16:14 +1100

tnftp (20090606-1) unstable; urgency=low

  * New upstream version 

 -- Anibal Monsalve Salazar <anibal@debian.org>  Tue, 09 Jun 2009 08:49:51 +1000

tnftp (20090520-1) unstable; urgency=low

  * New upstream version 
  * Build depend on quilt

 -- Anibal Monsalve Salazar <anibal@debian.org>  Wed, 27 May 2009 16:13:26 +1000

tnftp (20070806-3) unstable; urgency=low

  * Define ARG_MAX; patch thanks to peter green; closes: #518858

 -- Anibal Monsalve Salazar <anibal@debian.org>  Tue, 07 Apr 2009 08:47:25 +1000

tnftp (20070806-2) unstable; urgency=low

  * New maintainer; closes:  #472727
  * Define ARG_MAX; patch thanks to peter green; closes: #518858
  * Standards version is 3.8.1
  * debhelper compatibility is 7
  * Homepage is http://freshmeat.net/projects/tnftp/
  * Run dh_prep instead of dh_clean -k

 -- Anibal Monsalve Salazar <anibal@debian.org>  Mon, 06 Apr 2009 10:11:34 +1000

tnftp (20070806-1) unstable; urgency=low

  * QA upload.
  * Set maintainer to Debian QA Group.
  * New upstream version
  * Acknowledge NMUs. Thanks to Bastian Venthur and Luk Claes.
    Closes: #378914
  * Use a better formatted manpage. Closes: #430173
  * Use hardening-wrapper for building
  * Rewrite copyright
  * Build-Depend on debhelper >= 6
  * Clean up debian/rules
  * Update watch file
  * Update to Standards-Version 3.7.3
  * Fix error in manpage src/ftp.1
  * Lintian cleanups:
    - Remove DH_COMPAT from debian/rules
    - Do not ignore make clean error
    - Do not create /usr/sbin, it's not used

 -- Tobias Toedter <toddy@debian.org>  Wed, 23 Apr 2008 16:05:17 +0200

tnftp (20050625-0.2) unstable; urgency=high

  * Non-maintainer upload.
  * renamed binary from ftp to tnftp (Closes: #387717)
  * Urgency high due RCness of the bug

 -- Bastian Venthur <venthur@debian.org>  Thu,  1 Feb 2007 13:37:37 +0100

tnftp (20050625-0.1) unstable; urgency=medium

  * Non-maintainer upload.
  * New upstream version fixes CVE-2004-1294 (Closes: #285902).

 -- Luk Claes <luk@debian.org>  Wed, 19 Jul 2006 19:13:05 +0200

tnftp (2.0beta1-1) unstable; urgency=low

  * New upstream release
  * upstream program name has been changed.

 -- Takuo KITAME <kitame@debian.org>  Wed, 21 Jan 2004 12:49:57 +0900

lukemftp (1.5-8) unstable; urgency=low

  * Fix description
  * change maintainer address to @debian.org

 -- Takuo KITAME <kitame@debian.org>  Wed, 20 Nov 2002 04:53:16 +0900

lukemftp (1.5-7) unstable; urgency=low

  * fix for buffer overflow on PASV from malicious server. (closes: #146148)
    backported from
     http://www.freebsd.org/cgi/cvsweb.cgi/src/contrib/lukemftp/src/ftp.c
 
 -- Takuo KITAME <kitame@northeye.org>  Wed,  8 May 2002 10:37:45 +0900

lukemftp (1.5-6) unstable; urgency=low

  * remove Provides: ftp (closes: #130438)

 -- Takuo KITAME <kitame@northeye.org>  Fri, 25 Jan 2002 14:17:44 +0900

lukemftp (1.5-5) unstable; urgency=low

  * Added Build-Depends
  * Build-Depends: debhelper (>> 3.0.0) (closes: Bug#94950)

 -- Takuo KITAME <kitame@northeye.org>  Wed, 25 Apr 2001 01:25:50 +0900

lukemftp (1.5-4) unstable; urgency=low

  * Added alternatives mechanism support. (priority 110) (closes: Bug#82084)

 -- Takuo KITAME <kitame@northeye.org>  Tue, 13 Feb 2001 14:03:14 +0900

lukemftp (1.5-3) unstable; urgency=low

  * closes: Bug#77165
    Manpage installed by default is a cat page

 -- Takuo KITAME <kitame@northeye.org>  Fri, 17 Nov 2000 17:24:43 +0900

lukemftp (1.5-2) unstable; urgency=low

  * add 'lukem' into editline.3/editrc.5 filename. (closes: Bug#76965)

 -- Takuo KITAME <kitame@northeye.org>  Tue, 14 Nov 2000 18:40:46 +0900

lukemftp (1.5-1) unstable; urgency=low

  * New upstream release
  * lukemftp.h: #define	DEFAULTPAGER	"/usr/bin/pager" (closes: Bug#51147)

 -- Takuo KITAME <kitame@northeye.org>  Mon, 13 Nov 2000 10:10:34 +0900

lukemftp (1.1-1) unstable; urgency=low

  * New upstream version.

 -- Takuo KITAME <kitame@northeye.org>  Tue, 16 Nov 1999 21:47:28 +0900

lukemftp (1.0-1) unstable; urgency=low

  * Initial Release.

 -- Takuo KITAME <kitame@northeye.org>  Sun,  7 Nov 1999 22:45:54 +0900