File: changelog

package info (click to toggle)
tomcatjss 8.0.0-2
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, sid
  • size: 276 kB
  • sloc: java: 853; sh: 366; xml: 193; makefile: 24
file content (250 lines) | stat: -rw-r--r-- 7,506 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
tomcatjss (8.0.0-2) unstable; urgency=medium

  * rules: Fix classpath to look for the right coyote.jar.

 -- Timo Aaltonen <tjaalton@debian.org>  Wed, 20 Oct 2021 01:46:04 +0300

tomcatjss (8.0.0-1) unstable; urgency=medium

  * New upstream release.
  * control: Bump libjss-java depends.
  * rules: Drop building for old jdk target.
  * rules: Fix version.
  * control: Bump debhelper to 13.
  * rules: Drop obsolete build parameters.
  * control: Bump policy to 4.6.0.
  * control: Fix Vcs-Browser url.

 -- Timo Aaltonen <tjaalton@debian.org>  Tue, 19 Oct 2021 10:40:26 +0300

tomcatjss (7.7.0-1) unstable; urgency=medium

  * New upstream release.
  * rules: Fix source dir path.
  * control: Bump libjss-java dependency.

 -- Timo Aaltonen <tjaalton@debian.org>  Mon, 06 Sep 2021 11:48:16 +0300

tomcatjss (7.6.1-1) unstable; urgency=medium

  * New upstream release.
  * bump-version.diff: Dropped.

 -- Timo Aaltonen <tjaalton@debian.org>  Thu, 03 Dec 2020 14:50:31 +0200

tomcatjss (7.6.0-1) unstable; urgency=medium

  * New upstream release.
  * control: Build using libcommons-lang3-java, bump libjss depends.
  * bump-version.diff: Fix the project version.

 -- Timo Aaltonen <tjaalton@debian.org>  Sat, 31 Oct 2020 19:31:55 +0200

tomcatjss (7.5.0-1) unstable; urgency=medium

  * New upstream release.
  * control: Bump to debhelper-compat 12.
  * control: Bump policy to 4.5.0.
  * rules: Specify the location of tomcat9-util.jar.
  * control: Bump tomcat9 build-dep to fix ftbfs.

 -- Timo Aaltonen <tjaalton@debian.org>  Tue, 28 Jul 2020 14:15:37 +0300

tomcatjss (7.5.0~a1-1) experimental; urgency=medium

  * New upstream prerelease.
  * watch: Updated.
  * control: Bump libjss-java dependencies to 4.7.0~.

 -- Timo Aaltonen <tjaalton@debian.org>  Thu, 28 May 2020 00:39:50 +0300

tomcatjss (7.4.1-1) unstable; urgency=medium

  * New upstream release.

 -- Timo Aaltonen <tjaalton@debian.org>  Mon, 29 Jul 2019 12:03:59 +0300

tomcatjss (7.4.0-2) unstable; urgency=medium

  * Upload to unstable.

 -- Timo Aaltonen <tjaalton@debian.org>  Fri, 19 Jul 2019 10:15:08 +0300

tomcatjss (7.4.0-1) experimental; urgency=medium

  * New upstream release.
  * control: Bump libjss-java build-dep.
  * rules: Speficy where to find catalina.jar and tomcat-api.jar.

 -- Timo Aaltonen <tjaalton@debian.org>  Thu, 25 Apr 2019 16:09:13 +0300

tomcatjss (7.3.6-2) unstable; urgency=medium

  * control, rules: Migrate to tomcat9.

 -- Timo Aaltonen <tjaalton@debian.org>  Fri, 07 Dec 2018 10:30:20 +0200

tomcatjss (7.3.6-1) unstable; urgency=medium

  * New upstream release.
  * rules: Drop oscache.jar from classpath.
  * rules, control: Drop commons-logging from classpath and build-depends.

 -- Timo Aaltonen <tjaalton@debian.org>  Mon, 15 Oct 2018 10:12:10 +0300

tomcatjss (7.3.4-1) unstable; urgency=medium

  * New upstream release.
  * control: Bump dep on libjss-java.

 -- Timo Aaltonen <tjaalton@debian.org>  Wed, 15 Aug 2018 17:04:25 +0300

tomcatjss (7.3.3-1) unstable; urgency=medium

  * New upstream release.
  * control: Fix maintainer address.
  * Add dependency on libslf4j-java.
  * Bump dep on libjss-java.

 -- Timo Aaltonen <tjaalton@debian.org>  Sun, 05 Aug 2018 00:27:00 +0300

tomcatjss (7.3.0-2) unstable; urgency=medium

  * rules: Use javac target 1.8.
  * control: Change priority to optional.

 -- Timo Aaltonen <tjaalton@debian.org>  Thu, 03 May 2018 12:10:57 +0300

tomcatjss (7.3.0-1) unstable; urgency=medium

  * New upstream release. (Closes: #846677)
  * watch: Updated to point to github.
  * Bump debhelper to 11.
  * control: Bump policy to 4.1.4, no changes.
  * rules: Rework the build.

 -- Timo Aaltonen <tjaalton@debian.org>  Thu, 03 May 2018 09:37:58 +0300

tomcatjss (7.3.0~rc-1) experimental; urgency=medium

  * New upstream release candidate.
  * control: Update VCS urls.

 -- Timo Aaltonen <tjaalton@debian.org>  Tue, 17 Apr 2018 15:22:31 +0300

tomcatjss (7.3.0~git20180214-1) experimental; urgency=medium

  * New upstream snapshot.
  * Build against libtomcat8-java.
  * Drop fix-build.diff, use ant rules instead.
  * rules: Add get-orig-source target for snapshots.

 -- Timo Aaltonen <tjaalton@debian.org>  Thu, 15 Mar 2018 16:38:03 +0200

tomcatjss (7.2.4-1) unstable; urgency=medium

  * New upstream release.
  * control: Build-depend on libtomcat8.0-java.
  * control: Bump libjss-java build-dep to 4.4.2.
  * source/local-options: Ignore some files not in the tarball.

 -- Timo Aaltonen <tjaalton@debian.org>  Sat, 21 Oct 2017 11:19:37 +0300

tomcatjss (7.1.4-4) unstable; urgency=medium

  * control: Add breaks for pki-server versions which use tomcat7.

 -- Timo Aaltonen <tjaalton@debian.org>  Mon, 03 Oct 2016 20:35:27 +0300

tomcatjss (7.1.4-3) unstable; urgency=medium

  * Upload to unstable.

 -- Timo Aaltonen <tjaalton@debian.org>  Fri, 30 Sep 2016 15:30:17 +0300

tomcatjss (7.1.4-2) experimental; urgency=medium

  * control: Switch to tomcat8. (Closes: #759645)
  * control: Use https vcs urls.
  * control: Bump policy to 3.9.8, no changes.

 -- Timo Aaltonen <tjaalton@debian.org>  Wed, 31 Aug 2016 15:25:04 +0300

tomcatjss (7.1.4-1) unstable; urgency=medium

  * New upstream release.

 -- Timo Aaltonen <tjaalton@debian.org>  Wed, 31 Aug 2016 15:14:48 +0300

tomcatjss (7.1.3-3) unstable; urgency=medium

  * control: Revert to building with libtomcat7-java again.

 -- Timo Aaltonen <tjaalton@debian.org>  Thu, 24 Sep 2015 09:01:52 +0300

tomcatjss (7.1.3-2) unstable; urgency=medium

  * control: Depend on libtomcat8-java.

 -- Timo Aaltonen <tjaalton@debian.org>  Thu, 03 Sep 2015 17:33:05 +0300

tomcatjss (7.1.3-1) unstable; urgency=medium

  * New upstream release.
  * add-dummy-getprotocol.diff: Removed, upstream.

 -- Timo Aaltonen <tjaalton@debian.org>  Mon, 17 Aug 2015 08:45:11 +0300

tomcatjss (7.1.2-1) unstable; urgency=medium

  * New upstream release
    - support tomcat8
  * control: Build using libtomcat8-java, add libcommons-lang-java to
    build-depends.
  * fix-build.diff, add-dummy-getprotocol: Fix build. (Closes: #789109)

 -- Timo Aaltonen <tjaalton@debian.org>  Fri, 24 Jul 2015 00:30:09 +0300

tomcatjss (7.1.1-2) unstable; urgency=medium

  * control: Add versioned depends on libjss-java with TLS support to the
    binary too.

 -- Timo Aaltonen <tjaalton@debian.org>  Wed, 26 Nov 2014 15:50:17 +0200

tomcatjss (7.1.1-1) unstable; urgency=medium

  * New upstream release.
  * control: Bump libjss-java dependency so we have TLS support.
  * control: Update my email.
  * control: Bump policy to 3.9.6, no changes.

 -- Timo Aaltonen <tjaalton@debian.org>  Sat, 25 Oct 2014 13:24:40 +0300

tomcatjss (7.1.0-1) unstable; urgency=low

  [ Ade Lee ]
  * New upstream release. (Closes: #686879)
  * control: Depend on libtomcat7-java

  [ Timo Aaltonen ]
  * rules: Use bytecode format 1.5. (LP: #1049812)
  * control: Bump policy to 3.9.5, no changes.
  * control: Change the source section to java, like for the binary.

  [ Benjamin Drung ]
  * fix git URLs
  * use copyright format 1.0
  * switch to debhelper 9
  * drop unused ${shlibs:Depends} and add ${java:Depends}
  * fix architecture from any to all

 -- Timo Aaltonen <tjaalton@ubuntu.com>  Mon, 30 Jun 2014 12:40:23 +0200

tomcatjss (6.0.1-1) unstable; urgency=low

  * Initial release (Closes: #644371)
  * Conflict with libtcnative-1, which depends on openssl and breaks
    the NSS security model this package uses (see RHBZ #441974).

 -- Timo Aaltonen <tjaalton@ubuntu.com>  Fri, 29 Jun 2012 19:41:55 +0200