1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37
|
# Copyright (C) 2007 Miriam Ruiz <little_miry@yahoo.es>
# Distributed under the same license as the game. See debian/copyright.
@@ -129,6 +129,9 @@
case "-window":
Screen.windowMode = true;
break;
+ case "-fullscreen":
+ Screen.windowMode = false;
+ break;
case "-res":
if (i >= args.length - 2) {
usage(progName);
@@ -169,5 +172,5 @@
private void usage(char[] progName) {
Logger.error
- ("Usage: " ~ progName ~ " [-brightness [0-100]] [-luminosity [0-100]] [-window] [-res x y] [-nosound]");
+ ("Usage: " ~ progName ~ " [-brightness [0-100]] [-luminosity [0-100]] [-window] [-fullscreen] [-res x y] [-nosound]");
}
@@ -20,7 +20,7 @@
static float brightness = 1;
static int width = 640;
static int height = 480;
- static bool windowMode = false;
+ static bool windowMode = true;
static float nearPlane = 0.1;
static float farPlane = 1000;
private:
|