1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
|
include /usr/share/dpkg/pkg-info.mk
export DEB_VERSION_UPSTREAM
export TREE_SITTER_SRC_DIR = /usr/src/tree-sitter/lua/${DEB_VERSION_UPSTREAM}/
%:
dh $@
debian/%: debian/%.in
sed "s/@PARSER_VER@/$(DEB_VERSION_UPSTREAM)/g" $< > $@
override_dh_auto_build:
tree-sitter generate --no-bindings
dh_auto_build --buildsystem=rust
override_dh_auto_install:
dh_auto_install --buildsystem=rust
override_dh_install: debian/Makefile
dh_install
override_dh_auto_test:
XDG_CACHE_HOME=$(CURDIR)/debian/.cache tree-sitter test
dh_auto_test --buildsystem=rust
|