File: control

package info (click to toggle)
tulip 5.4.0%2Bdfsg-3
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, sid
  • size: 208,716 kB
  • sloc: cpp: 613,411; makefile: 22,047; ansic: 11,295; python: 4,606; sh: 709; yacc: 522; pascal: 157; php: 66; xml: 56; lex: 55
file content (143 lines) | stat: -rw-r--r-- 4,556 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
Source: tulip
Section: graphics
Priority: optional
Maintainer: Debian Science Team <debian-science-maintainers@lists.alioth.debian.org>
Uploaders: James Turton <james@somecomputer.xyz>
Build-Depends:
  debhelper-compat (= 12),
          ca-certificates,
          cmake,
          ninja-build,
          doxygen,
          graphviz,
          libqhull-dev,
          libyajl-dev,
          libcppunit-dev,
          qtbase5-dev,
          libqt5opengl5-dev,
          libqt5webkit5-dev,
          libquazip5-dev,
          libftgl-dev,
          libglew-dev,
          libpng-dev,
          libjpeg-dev,
          libfreetype6-dev,
          libutfcpp-dev,
          python3,
          python3-distutils,
          python3-sphinx,
          libpython3-dev,
          python3-sip-dev,
          libgzstream-dev,
          libantlr-dev,
          docbook-to-man
Build-Conflicts: binutils-dev
Rules-Requires-Root: no
Homepage: http://tulip.labri.fr/
Standards-Version: 4.5.1
Vcs-browser: https://salsa.debian.org/science-team/tulip
Vcs-git: https://salsa.debian.org/science-team/tulip.git

Package: tulip
Architecture: any
Depends: ${shlibs:Depends},
  ${misc:Depends},
  python3,
  fonts-dejavu-core,
  fonts-font-awesome,
  fonts-materialdesignicons-webfont,
  libjs-leaflet,
  python3-sip
Suggests: qtwayland5
Description: System dedicated to the visualization of huge data sets as graphs
 Tulip is an information visualization framework dedicated to the analysis and
 visualization of relational data.  It aims to provide the developer with a
 complete library, supporting the design of interactive information
 visualization applications for relational data that can be tailored to the
 problems he or she is addressing.
 .
 It includes the following features:
 .
  * 3D visualizations
  * 3D modifications
  * Plug-in support for easy evolution
  * Building of clusters and navigation into them
  * Automatic drawing of graphs
  * Automatic clustering of graphs
  * Automatic selection of elements
  * Automatic metric coloration of graphs

Package: libtulip-dev
Section: libdevel
Architecture: any
Depends: tulip (= ${binary:Version}), libc6-dev, ${misc:Depends}
Conflicts: libtulip-dev
Replaces: tulip (<= 2), libtulip-ogl-dev, libtulip-qt4-dev
Suggests: cmake
Enhances: qtcreator
Description: Tulip graph library - core development files
 Headers and static libraries for tulip, a system dedicated to the
 visualization of huge graphs.  Also includes QtCreator templates.

Package: libtulip-core-5.4
Section: libs
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
Description: Tulip graph library - core runtime
 Runtime for tulip, a system dedicated to the visualization of huge graphs.
 .
 This is the core of the system, excluding the OpenGL rendering capabilities.

Package: libtulip-ogl-5.4
Section: libs
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
Description: Tulip graph library - OpenGL runtime
 Runtime for tulip, a system dedicated to the visualization of huge graphs.
 .
 This library contains the OpenGL rendering capabilities of the engine.

Package: libtulip-gui-5.4
Section: libs
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
Description: Tulip graph library - Qt/OpenGL GUI runtime
 Runtime for tulip, a system dedicated to the visualization of huge graphs.
 .
 This library contains the Qt/OpenGL GUI support.

Package: libtulip-python-5.4
Section: libs
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
Provides: libtulip-python
Conflicts: libtulip-python
Description: Tulip graph library - Python support
 Runtime for tulip, a system dedicated to the visualization of huge graphs.
 .
 This library contains the Python scripting support.

Package: libtulip-ogdf-5.4
Section: libs
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
Description: Tulip graph library - OGDF runtime
 Runtime for tulip, a system dedicated to the visualization of huge graphs.
 .
 This library contains the Open Graph Drawing Framework support.

Package: libogdf-tulip-5.4-0
Section: libs
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
Description: Open Graph Drawing Framework shared library, built for Tulip
 This is the Open Graph Drawing Framework library, built as a shared
 lib as required by Tulip.

Package: libtess2-tulip-5.4
Section: libs
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
Description: Libtess2 shared library, built for Tulip
 Runtime for Libtess2 polygon tesselator and triangulator, built as a
 shared lib as required by Tulip.