File: changelog

package info (click to toggle)
twitter-bootstrap3 3.4.1+dfsg-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 9,664 kB
  • sloc: javascript: 27,371; makefile: 88; ruby: 31
file content (258 lines) | stat: -rw-r--r-- 8,931 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
twitter-bootstrap3 (3.4.1+dfsg-2) unstable; urgency=medium

  [ Xavier Guimard ]
  * Replace Jonas Smedegaard by myself to uploaders. Thanks for your work!
    (Closes: #918197)
  * Apply multi-arch hints (foreign) (Closes: #923518)

  [ Debian Janitor ]
  * Set debhelper-compat version in Build-Depends.
  * Update renamed lintian tag names in lintian overrides.
  * Remove obsolete fields Contact, Name from debian/upstream/metadata
    (already present in machine-readable debian/copyright).
  * Update standards version to 4.5.0, no changes needed.

  [ Xavier Guimard ]
  * Replace build-dependency to node-uglify by uglifyjs (Closes: #979961)
  * Bump debhelper compatibility level to 13
  * Declare compliance with policy 4.5.1
  * Add "Rules-Requires-Root: no"
  * Modernize debian/watch

 -- Xavier Guimard <yadd@debian.org>  Tue, 12 Jan 2021 12:16:16 +0100

twitter-bootstrap3 (3.4.1+dfsg-1) unstable; urgency=medium

  * Team upload
  * Exclude .gitignore from upstream archive
  * New upstream version 3.4.1+dfsg. Fixes CVE-2019-8331
  * Update debian/copyright

 -- Xavier Guimard <yadd@debian.org>  Fri, 22 Feb 2019 10:25:16 +0100

twitter-bootstrap3 (3.4.0+dfsg-4) unstable; urgency=medium

  * Generate README.txt and README.html from README.md.
    Build-depend on pandoc.
  * Enable autopkgtest.
  * Fix have libjs-bootstrap depend on fonts-glyphicons-halflings
    (not bogus fonts-glyhicons-halflings).
  * Add patch 2001 to fix privacy issues in documentation.

 -- Jonas Smedegaard <dr@jones.dk>  Tue, 22 Jan 2019 00:06:11 +0100

twitter-bootstrap3 (3.4.0+dfsg-3) unstable; urgency=medium

  * Update rules: Revert preparation of fonts,
    and instead omit installing them in debhelper hint.

 -- Jonas Smedegaard <dr@jones.dk>  Mon, 21 Jan 2019 22:34:34 +0100

twitter-bootstrap3 (3.4.0+dfsg-2) experimental; urgency=medium

  * Update copyright info:
    + Fix add Files section for fonts,
      and clarify licensing of main code and documentation.
    + Fix update Files section for customizer.js,
      add clarify its current licensing.
  * Wrap and sort control file.
  * Use dpkg snippet to resolve version string.
  * Fix add binary package fonts-glyphicons-halflings.
  * Add myself as uploader.

 -- Jonas Smedegaard <dr@jones.dk>  Mon, 21 Jan 2019 17:13:09 +0100

twitter-bootstrap3 (3.4.0+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Antonio Terceiro ]
  * debian/rules: use UTC dates to avoid unreproducibility across timezones
    during new year's eve/day.

  [ Jelmer Vernooij ]
  * Use secure copyright file specification URI.

  [ Xavier Guimard ]
  * New upstream version 3.4.0+dfsg (Closes: #907414)
  * Bump debhelper compatibility level to 12
  * Declare compliance with policy 4.3.0
  * Update VCS URLs
  * Update debian/copyright
  * Update lintian overrides
  * Change section to javascript
  * Add upstream/metadata
  * Update upstream changelog
  * Remove get-orig-source target in debian/rules
  * Update links to https

 -- Xavier Guimard <yadd@debian.org>  Fri, 04 Jan 2019 07:27:13 +0100

twitter-bootstrap3 (3.3.7+dfsg-2) unstable; urgency=medium

  * Team upload
  * debian/upstream/changelog: update with changelog entries for 3.3.7
  * debian/rules: produce reproducible copyright message in
    dist/js/bootstrap3.js (Closes: #834988)

 -- Antonio Terceiro <terceiro@debian.org>  Mon, 24 Oct 2016 10:45:58 -0200

twitter-bootstrap3 (3.3.7+dfsg-1) unstable; urgency=medium

  * Team upload
  * New upstream version 3.3.7+dfsg
    - Adds compatibility with jQuery 3
  * debian/rules: update the jQuery version check
  * Bump Standards-Version to 3.9.8; no changes needed
  * Switch Git* URL's to https

 -- Antonio Terceiro <terceiro@debian.org>  Sat, 22 Oct 2016 20:20:37 -0200

twitter-bootstrap3 (3.3.6+dfsg-1) unstable; urgency=medium

  * Track version 3
  * Drop unsuitable images

 -- David Prévot <taffit@debian.org>  Sat, 19 Dec 2015 10:54:42 -0400

twitter-bootstrap3 (3.3.5+dfsg-2) unstable; urgency=medium

  * Add node-source-map to build-dependencies.
    Thanks to Jonas Smedegaard (Closes: #802527)

 -- David Prévot <taffit@debian.org>  Fri, 23 Oct 2015 13:11:28 -0400

twitter-bootstrap3 (3.3.5+dfsg-1) unstable; urgency=medium

  [ XhmikosR ]
  * Fix license header

 -- David Prévot <taffit@debian.org>  Sat, 20 Jun 2015 16:35:10 -0400

twitter-bootstrap3 (3.3.4+dfsg-2) unstable; urgency=medium

  * Upload to unstable since Jessie has been released

 -- David Prévot <taffit@debian.org>  Sun, 17 May 2015 09:06:25 -0400

twitter-bootstrap3 (3.3.4+dfsg-1) experimental; urgency=medium

  * Update copyright

 -- David Prévot <taffit@debian.org>  Thu, 19 Mar 2015 16:56:48 -0400

twitter-bootstrap3 (3.3.2+dfsg-1) experimental; urgency=medium

  * Update copyright

 -- David Prévot <taffit@debian.org>  Thu, 29 Jan 2015 19:22:15 -0400

twitter-bootstrap3 (3.3.1+dfsg-1) experimental; urgency=medium

  * Upload to experimental to respect the freeze

  [ Mark Otto ]
  * bump version to v3.3.1

  [ David Prévot ]
  * Use repacksuffix feature of uscan
  * Update copyright
  * Add upstream changelog
  * Bump standards version to 3.9.6
  * Update rules

 -- David Prévot <taffit@debian.org>  Fri, 12 Dec 2014 23:01:18 -0400

twitter-bootstrap3 (3.2.0+dfsg-1) unstable; urgency=medium

  * Restart packaging for twitter-bootstrap3 (Closes: #722935)
  * Do not install documentation
  * Provide less files, as suggested in #731750

 -- David Prévot <taffit@debian.org>  Sun, 14 Sep 2014 15:14:28 -0400

twitter-bootstrap (2.0.2+dfsg-4) unstable; urgency=low

  * QA upload.
  * debian/patches/build-with-node-1.4.2.patch: Add patch from upstream
    git to build with node 1.4.2 (Closes: #718072)
  * Updating to Standards version 3.9.4
  * Update copyright file to clarify license
  * Include a watchfile
  * Don't duplicate "Section"-field in libjs-twitter-bootstrap
  * Don't use obsolete Apache2 conf.d directory
  * Add a doc-base file for the documentation package

 -- Andreas Moog <amoog@ubuntu.com>  Sat, 10 Aug 2013 18:57:51 +0000

twitter-bootstrap (2.0.2+dfsg-3) unstable; urgency=low

  * QA upload
  * The package has been orphaned. Set maintainer to Debian QA Group.
  * Use nodejs command instead of the obsolete node command to build the
    documentation. (Closes: #707522)

 -- Markus Koschany <apo@gambaru.de>  Sat, 08 Jun 2013 23:09:56 +0200

twitter-bootstrap (2.0.2+dfsg-2) unstable; urgency=low

  * Switching to xz compression.
  * Updating GPL boilerplate in copyright file.
  * Sorting fields in proper order in copyright file.
  * Removing useless additional license file.
  * Adding missing continuation line in copyright file.
  * Removing obsoleted copyright symbols in copyright file.

 -- Daniel Baumann <daniel.baumann@progress-technologies.net>  Sat, 30 Jun 2012 15:48:58 +0200

twitter-bootstrap (2.0.2+dfsg-1) unstable; urgency=low

  * Merging upstream version 2.0.2+dfsg.
  * Rediffing dfsg.patch.
  * Rediffing build.patch.
  * Making build-depends on less.js versioned.
  * Updating to debhelper version 9.
  * Updating to standards version 3.9.3.
  * Updating copyright file machine-readable format version 1.0.

 -- Daniel Baumann <daniel.baumann@progress-technologies.net>  Tue, 20 Mar 2012 12:20:34 +0100

twitter-bootstrap (2.0+dfsg-1) unstable; urgency=low

  * Merging upstream version 2.0+dfsg.
  * Updating rules for version 2.0.
  * Updating copyright file for version 2.0.
  * Removing date.patch, not required anymore.
  * Updating local copy of html5shiv.
  * Adding node-uglify to build-depends.
  * Adding zip to build-depends.
  * Adding patch to avoid trying to copy not included jquery.js file.
  * Adding patch to avoid removing files after build.
  * Updating debhelper files for new fs layout.
  * Using uppercase spelling of html in package descriptions.
  * Adding todo file.
  * Dropping usage of javascript-common and using more suitable
    /twitter-bootstrap and /bootstrap configurations without loosing
    javascript-common compatiblity.
  * Also compressing local css file.

 -- Daniel Baumann <daniel.baumann@progress-technologies.net>  Sat, 11 Feb 2012 09:40:17 +0100

twitter-bootstrap (1.4+dfsg-2) unstable; urgency=low

  * Adding provides twitter-bootstrap and twitter-bootstrap-docs to
    libjs-t-b and libjs-t-b-d respectively.
  * Adding local copy of html5shiv, version 20120101.
  * Adding local copy of google-code-prettify, version 20110601.
  * Installing compressed variants of all javascript files.
  * Adding recommends to libjs-jquery and libjs-jquery-tablesorter.

 -- Daniel Baumann <daniel.baumann@progress-technologies.net>  Sat, 07 Jan 2012 23:06:55 +0100

twitter-bootstrap (1.4+dfsg-1) unstable; urgency=low

  * Initial release (Closes: #647864).
  * Rebuild upstream tarball without browser and twitter icons
    and google-code-prettify.

 -- Daniel Baumann <daniel.baumann@progress-technologies.net>  Wed, 28 Dec 2011 08:10:28 +0100