File: changelog

package info (click to toggle)
tycho 1.0.0-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 18,508 kB
  • sloc: java: 62,811; xml: 29,982; sh: 50; makefile: 10
file content (72 lines) | stat: -rw-r--r-- 2,346 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
tycho (1.0.0-2) unstable; urgency=medium

  * Team upload.
  * Fixed the compatibility with equinox-p2 4.8

 -- Emmanuel Bourg <ebourg@apache.org>  Wed, 19 Dec 2018 15:56:23 +0100

tycho (1.0.0-1) unstable; urgency=medium

  * Team upload.

  [ Christopher Hoskin ]
  * Add debian/clean 

  [ Emmanuel Bourg ]
  * New upstream release
    - Refreshed the patches
    - Ignore the new test modules
    - Removed the dependency on libcommons-httpclient-java
    - Removed the dependency on libcommons-jxpath-java
  * Use the Eclipse Aether/Maven Resolver API instead of Sonatype Aether
  * Replaced the embedded bundles with dependencies on eclipse/equinox packages
  * Disabled the lock file marker created in /usr/share/maven-repo/
  * Patched DefaultEquinoxEmbedder to throw explicit exception messages
  * Simplified the Maven rules
  * Added a watch file
  * Standards-Version updated to 4.2.1
  * Switch to debhelper level 11
  * Use salsa.debian.org Vcs-* URLs

 -- Emmanuel Bourg <ebourg@apache.org>  Sun, 28 Oct 2018 10:46:11 +0100

tycho (0.25.0-4) unstable; urgency=medium

  * Team upload.
  * Added the missing build dependency on libcommons-httpclient-java
    (Closes: #881335)
  * Fixed the compilation errors with Java 9 (Closes: #874130)
  * Removed the unused build dependency on glassfish-javaee

 -- Emmanuel Bourg <ebourg@apache.org>  Thu, 23 Nov 2017 14:58:03 +0100

tycho (0.25.0-3) unstable; urgency=medium

  * Remove obsolete maven rules for bcel artifact.
    Thanks to Adrian Bunk for the report. (Closes: #879250)
  * Declare compliance with Debian Policy 4.1.1.

 -- Markus Koschany <apo@debian.org>  Sat, 21 Oct 2017 12:33:16 +0200

tycho (0.25.0-2) unstable; urgency=medium

  [ Emmanuel Bourg ]
  * Depend on asm (>= 5.0) instead of libasm4-java.

  [ Markus Koschany ]
  * Declare compliance with Debian Policy 4.1.0.
  * Add plexus-compatibility.patch and fix FTBFS with the latest
    plexus-archiver version. (Closes: #871347)

  [ Christopher Hoskin ]
  * Fix copyright paths with spaces.

 -- Markus Koschany <apo@debian.org>  Sat, 02 Sep 2017 02:35:30 +0200

tycho (0.25.0-1) unstable; urgency=medium

  * Initial release. (Closes: #816604)
  * Thanks to Luca Vercelli and Christopher Hoskin for their initial work on
    this package.

 -- Markus Koschany <apo@debian.org>  Tue, 29 Nov 2016 21:42:39 +0100