1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38
|
DESTDIR=$(CURDIR)/debian/tmp
include /usr/share/ocaml/ocamlvars.mk
export OCAMLFIND_DESTDIR := $(DESTDIR)/$(OCAML_STDLIB_DIR)
%:
dh $@ --with ocaml
.PHONY: override_dh_install
override_dh_install:
dh_install --list-missing
.PHONY: override_dh_auto_configure
override_dh_auto_configure:
$(MAKE) configure
./configure --prefix /usr --disable-ppx --destdir '$(DESTDIR)' --docdir '$(DESTDIR)/usr/share/doc/libtyxml-ocaml-dev'
.PHONY: override_dh_auto_build
override_dh_auto_build:
$(MAKE) build
$(MAKE) doc
.PHONY: override_dh_auto_test
override_dh_auto_test:
$(MAKE) test
.PHONY: override_dh_auto_install
override_dh_auto_install:
mkdir -p '$(OCAMLFIND_DESTDIR)'
$(MAKE) install
.PHONY: override_dh_auto_clean
override_dh_auto_clean:
$(MAKE) distclean
|