1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36
|
export PYBUILD_NAME=ufl_legacy
export PYBUILD_DISABLE=test
DEB_DESTDIR = $(CURDIR)/debian/tmp
USCAN_DESTDIR := $(CURDIR)
PY3VER_DEFAULT := $(shell py3versions -dv)
%:
dh $@ --with python3,sphinxdoc --buildsystem=pybuild
execute_after_dh_clean:
rm -rf *.egg-info
rm -rf doc/sphinx/source/api-doc
ifeq (,$(filter nodoc,$(DEB_BUILD_OPTIONS)))
execute_after_dh_auto_clean:
$(MAKE) -C doc/sphinx clean
endif
execute_after_dh_auto_install:
ifeq (,$(filter nodoc,$(DEB_BUILD_OPTIONS)))
PYTHONPATH=$(CURDIR)/debian/python3-ufl-legacy/usr/lib/python$(PY3VER_DEFAULT)/dist-packages:${PYTHONPATH} $(MAKE) -C doc/sphinx html
endif
override_dh_compress:
dh_compress -X.py -X.ufl
.PHONY: get-orig-source
get-orig-source:
uscan --force-download --verbose --destdir $(USCAN_DESTDIR)
|