1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
|
include /usr/share/dpkg/pkg-info.mk
pkg = node-uglify
DEB_SUITE_EXP = $(filter experimental% UNRELEASED,$(DEB_DISTRIBUTION))
%:
dh $@
override_dh_auto_build:
nodejs bin/uglifyjs \
--self \
--comments /Copyright/ \
--output debian/uglify.js
NODE_PATH=lib help2man \
--name="JavaScript parser, mangler/compressor and beautifier toolkit" \
--no-info \
--output=debian/uglifyjs.1 \
bin/uglifyjs \
|| { NODE_PATH=lib bin/uglifyjs --help; false; }
override_dh_auto_test:
NODE_PATH=lib nodejs test/run-tests.js \
$(if $(DEB_SUITE_EXP),|| true)
override_dh_fixperms:
dh_fixperms
chmod a+x debian/$(pkg)/usr/lib/nodejs/uglify-js/bin/extract-props.js
|