1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61
|
include /usr/share/dpkg/architecture.mk
EXTRA_CONF_OPTS =
EXTRA_DH_OPTS =
nojava_archs = hppa
ifneq (,$(filter $(DEB_HOST_ARCH), $(nojava_archs)))
export DEB_BUILD_PROFILES += nojava
endif
ifeq ($(filter nojava,$(DEB_BUILD_PROFILES)),)
export JAVA_HOME = /usr/lib/jvm/default-java
export CLASSPATH = /usr/share/java/log4j-1.2.jar
EXTRA_DH_OPTS += --with javahelper
EXTRA_CONF_OPTS += --enable-jni-interface \
--enable-java-agent-all \
--with-java-prefix=$(JAVA_HOME)
endif
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_PYTHON_INSTALL_LAYOUT = deb
%:
dh $@ --with=python3 $(EXTRA_DH_OPTS)
override_dh_auto_configure:
PYTHON=python3 \
dh_auto_configure -- \
--includedir=/usr/include/$(DEB_HOST_MULTIARCH) \
--enable-python-agent \
$(EXTRA_CONF_OPTS)
ifeq ($(filter nojava,$(DEB_BUILD_PROFILES)),)
override_dh_makeshlibs:
dh_makeshlibs -V -X/usr/lib/$(DEB_HOST_MULTIARCH)/jni
override_jh_manifest:
jh_manifest -pliblttng-ust-agent-java
endif
override_dh_auto_test:
ifeq ($(shell dpkg-buildflags --get LDFLAGS | grep -q -- '-Wl,-Bsymbolic-functions' && echo yes),yes)
dh_auto_test -- UST_TESTS_LD_SYMBOLIC_FUNC=1
else
dh_auto_test
endif
execute_after_dh_auto_clean:
rm -f src/python-lttngust/installed_files.txt
rm -rf src/python-lttngust/lttngust.egg-info
|