1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
|
include /usr/share/dpkg/pkg-info.mk
UWSGI_VERSION = $(shell dpkg-query --show --showformat '$${Version}' uwsgi-src)
OUR_BINARY_VERSION = $(subst -,+,$(UWSGI_VERSION))+$(DEB_VERSION)
PLUGINBUILDER = uwsgi --build-plugin
%:
dh $@
%_plugin.so:
$(PLUGINBUILDER) /usr/src/uwsgi/plugins/$*
override_dh_auto_build: glusterfs_plugin.so
help2man \
--name 'fast (pure C), self-healing, developer-friendly WSGI server' \
--section 1 \
--no-info \
--version-string="$(UWSGI_VERSION)" \
debian/uwsgi_glusterfs \
> debian/uwsgi_glusterfs.1
override_dh_gencontrol:
dh_gencontrol -- -v$(OUR_BINARY_VERSION)
|