1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53
|
include /usr/share/dpkg/architecture.mk
%:
dh $@
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
override_dh_auto_configure:
dh_auto_configure -- \
-Dvalijson_INSTALL_HEADERS=ON \
-Dvalijson_EXCLUDE_BOOST=ON \
-Dvalijson_BUILD_TESTS=ON
override_dh_auto_test:
cd obj-$(DEB_HOST_MULTIARCH) && ./test_suite
else
override_dh_auto_configure:
dh_auto_configure -- \
-Dvalijson_INSTALL_HEADERS=ON \
-Dvalijson_EXCLUDE_BOOST=ON \
-Dvalijson_BUILD_TESTS=OFF
override_dh_auto_build:
true
override_dh_auto_test:
true
endif
override_dh_compress:
dh_compress -X.cpp -XREADME
|