File: autogen.sh

package info (click to toggle)
varnish 5.0.0-7+deb9u2
  • links: PTS, VCS
  • area: main
  • in suites: stretch
  • size: 13,820 kB
  • sloc: ansic: 75,629; sh: 11,818; python: 1,948; makefile: 1,246; ruby: 44
file content (51 lines) | stat: -rwxr-xr-x 844 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
#!/bin/sh
#

warn() {
	echo "WARNING: $@" 1>&2
}

case `uname -s` in
Darwin)
    LIBTOOLIZE=glibtoolize
    ;;
FreeBSD)
    LIBTOOLIZE=libtoolize
    ;;
NetBSD)
    LIBTOOLIZE=libtoolize
    ;;
OpenBSD)
    LIBTOOLIZE=libtoolize
    ;;
Linux)
    LIBTOOLIZE=libtoolize
    ;;
SunOS)
    LIBTOOLIZE=libtoolize
    ;;
*)
    warn "unrecognized platform:" `uname -s`
    LIBTOOLIZE=libtoolize
esac

automake_version=`automake --version | tr ' ' '\n' | egrep '^[0-9]\.[0-9a-z.-]+'`
if [ -z "$automake_version" ] ; then
    warn "unable to determine automake version"
else
    case $automake_version in
	0.*|1.[0-8]|1.[0-8][.-]*)
	    warn "automake ($automake_version) detected; 1.9 or newer recommended"
	    ;;
	*)
	    ;;
    esac
fi

set -ex

$LIBTOOLIZE --copy --force
aclocal -I m4
autoheader
automake --add-missing --copy --foreign
autoconf