1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32
|
Description: fix hardcoded install dirs
Author: Stephan Lachnit <stephanlachnit@debian.org>
Forwarded: https://github.com/dpiparo/vdt/pull/15
@@ -5,6 +5,7 @@
#-------------------------------------------------------------------------------
# Include the defaults
include ( CMakeDefaults.txt )
+include ( GNUInstallDirs )
#-------------------------------------------------------------------------------
# configuration options -- you may change them when running cmake
@@ -214,5 +215,5 @@
include/tan.h
include/vdtcore_common.h
include/vdtMath.h
- DESTINATION include/vdt)
+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/vdt)
@@ -20,7 +20,7 @@
# Installation of the lib
INSTALL(TARGETS vdt
- DESTINATION lib)
+ DESTINATION ${CMAKE_INSTALL_LIBDIR})
# Build Vc wrapper (without c++11)
|