1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87
|
export DEB_BUILD_MAINT_OPTIONS += hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/architecture.mk
include /usr/share/dpkg/buildflags.mk
include /usr/share/dpkg/pkg-info.mk
ifneq (,$(filter $(DEB_HOST_ARCH), mipsel))
export DEB_CPPFLAGS_MAINT_APPEND += -g1
endif
CLEAN_OUT_DATA := \
config.log \
configure \
docs/_build \
src/config_rev.h \
verilator-config.cmake \
verilator-config-version.cmake \
verilator.pc \
$(NULL)
%:
dh $@
override_dh_clean:
dh_clean
if [ -f debian/config_rev.save ]; then \
cp -f debian/config_rev.save src/config_rev ;\
fi
rm -rf $(CLEAN_OUT_DATA)
override_dh_autoreconf:
if [ ! -f debian/config_rev.save ]; then \
cp src/config_rev debian/config_rev.save ;\
fi
sed -i 's/UNKNOWN_REV/(Debian $(DEB_VERSION))/g' src/config_rev
autoconf
override_dh_auto_build:
dh_auto_build
cd docs && make html
cd docs && make pdf
override_dh_compress:
dh_compress --exclude=examples --exclude=verilator.pdf
override_dh_fixperms:
dh_fixperms
for file in `find $(CURDIR)/debian/verilator/usr/share/verilator/examples -type f`; do \
FOUND_PYTHON=$$(head -n1 $$file | grep python); \
if [ "$$FOUND_PYTHON" != "" ]; then \
chmod +x $$file; \
else \
chmod -x $$file; \
fi; \
done
override_dh_auto_test:
ifeq (,$(filter armel mipsel mips64el,$(DEB_BUILD_ARCH)))
dh_auto_test
else
@echo "#########################################"
@echo "# Skipping calling dh_auto_test on $(DEB_BUILD_ARCH)"
@echo "#########################################"
endif
override_dh_dwz:
|