File: README

package info (click to toggle)
vim-vimerl 1.4.1%2Bgit20120509.89111c7-2.1
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, sid
  • size: 212 kB
  • sloc: erlang: 1,002; sh: 12; makefile: 2
file content (50 lines) | stat: -rw-r--r-- 1,142 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
   _    ___                     __
  | |  / (_)___ ___  ___  _____/ /
  | | / / / __ `__ \/ _ \/ ___/ /
  | |/ / / / / / / /  __/ /  / /
  |___/_/_/ /_/ /_/\___/_/  /_/
====================================

The Erlang plugin for Vim.


 Features
----------

- Syntax highlighting
- Code indenting
- Code folding
- Code omni completion
- Syntax checking with quickfix support
- Code skeletons for the OTP behaviours
- Uses configuration from Rebar
- Pathogen compatible (http://github.com/tpope/vim-pathogen)


 How to install it
-------------------

Copy the content of the tarball to your `.vim'. Don't forget to run
`:helptags' if you are not using Pathogen.

Vimerl requires to have a recent version of Erlang installed in your
system with `escript' in your $PATH.

With a Vim version older than 7.3 syntax checking will be disabled as
some required features won't be available.


 How to use it
---------------

Start with `:help vimerl'.


 How to contribute or report bugs
----------------------------------

Send it to me:
    Ricardo Catalinas Jiménez <jimenezrick@gmail.com>

Or use GitHub:
    http://github.com/jimenezrick/vimerl